aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.19/728-phy-rtl8367b.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2015-01-25 15:20:39 +0000
committerImre Kaloz <kaloz@openwrt.org>2015-01-25 15:20:39 +0000
commitd26694243af236fed09a4b38f3cc68e40ad063b5 (patch)
treedf356ae59718ae0996986ccb61155243098dbc3f /target/linux/generic/patches-3.19/728-phy-rtl8367b.patch
parenta46bb6ec6a0ed6eb56dc2f4551a57e63a7292753 (diff)
downloadupstream-d26694243af236fed09a4b38f3cc68e40ad063b5.tar.gz
upstream-d26694243af236fed09a4b38f3cc68e40ad063b5.tar.bz2
upstream-d26694243af236fed09a4b38f3cc68e40ad063b5.zip
generic: add preliminary 3.19 support
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> SVN-Revision: 44126
Diffstat (limited to 'target/linux/generic/patches-3.19/728-phy-rtl8367b.patch')
-rw-r--r--target/linux/generic/patches-3.19/728-phy-rtl8367b.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.19/728-phy-rtl8367b.patch b/target/linux/generic/patches-3.19/728-phy-rtl8367b.patch
new file mode 100644
index 0000000000..2053b52b5d
--- /dev/null
+++ b/target/linux/generic/patches-3.19/728-phy-rtl8367b.patch
@@ -0,0 +1,23 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -276,6 +276,10 @@ config RTL8367_PHY
+ tristate "Driver for the Realtek RTL8367R/M switches"
+ select SWCONFIG
+
++config RTL8367B_PHY
++ tristate "Driver fot the Realtek RTL8367R-VB switch"
++ select SWCONFIG
++
+ endif # RTL8366_SMI
+
+ endif # PHYLIB
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -28,6 +28,7 @@ obj-$(CONFIG_RTL8366_SMI) += rtl8366_smi
+ obj-$(CONFIG_RTL8366S_PHY) += rtl8366s.o
+ obj-$(CONFIG_RTL8366RB_PHY) += rtl8366rb.o
+ obj-$(CONFIG_RTL8367_PHY) += rtl8367.o
++obj-$(CONFIG_RTL8367B_PHY) += rtl8367b.o
+ obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
+ obj-$(CONFIG_FIXED_PHY) += fixed_phy.o
+ obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o