aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.18/733-phy_mvsw61xx.patch
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2015-01-11 17:19:58 +0000
committerLuka Perkov <luka@openwrt.org>2015-01-11 17:19:58 +0000
commita1872182bb252ac9d731cbc8af0e9ddb75fc8cb0 (patch)
tree6415652f87a8a594689e4ebe65992434e22b0be7 /target/linux/generic/patches-3.18/733-phy_mvsw61xx.patch
parente0daabc8ec87210654eef22c57c5486904438cd9 (diff)
downloadupstream-a1872182bb252ac9d731cbc8af0e9ddb75fc8cb0.tar.gz
upstream-a1872182bb252ac9d731cbc8af0e9ddb75fc8cb0.tar.bz2
upstream-a1872182bb252ac9d731cbc8af0e9ddb75fc8cb0.zip
mvsw6171: rename to 'mvsw61xx'
In preparation for properly supporting switches beyond the 88E6171. Signed-off-by: Claudio Leite <leitec@staticky.com> SVN-Revision: 43935
Diffstat (limited to 'target/linux/generic/patches-3.18/733-phy_mvsw61xx.patch')
-rw-r--r--target/linux/generic/patches-3.18/733-phy_mvsw61xx.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.18/733-phy_mvsw61xx.patch b/target/linux/generic/patches-3.18/733-phy_mvsw61xx.patch
new file mode 100644
index 0000000000..041d168b65
--- /dev/null
+++ b/target/linux/generic/patches-3.18/733-phy_mvsw61xx.patch
@@ -0,0 +1,23 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -143,6 +143,10 @@ config MVSWITCH_PHY
+ tristate "Driver for Marvell 88E6060 switches"
+ select ETHERNET_PACKET_MANGLE
+
++config MVSW61XX_PHY
++ tristate "Driver for Marvell 88E6171/6172 switches"
++ select SWCONFIG
++
+ config IP17XX_PHY
+ tristate "Driver for IC+ IP17xx switches"
+ select SWCONFIG
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -20,6 +20,7 @@ obj-$(CONFIG_BCM87XX_PHY) += bcm87xx.o
+ obj-$(CONFIG_ICPLUS_PHY) += icplus.o
+ obj-$(CONFIG_ADM6996_PHY) += adm6996.o
+ obj-$(CONFIG_MVSWITCH_PHY) += mvswitch.o
++obj-$(CONFIG_MVSW61XX_PHY) += mvsw61xx.o
+ obj-$(CONFIG_IP17XX_PHY) += ip17xx.o
+ obj-$(CONFIG_REALTEK_PHY) += realtek.o
+ obj-$(CONFIG_AR8216_PHY) += ar8216.o ar8327.o