aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.14
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-01-02 21:52:35 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-01-02 21:52:35 +0000
commit4153c0adff074167f1eb934235129471d2c04199 (patch)
tree9e90c8956937880242065443a6da0d8a0ed22aff /target/linux/generic/patches-3.14
parent6bfd210ade2a5d35950f56aeeac2d0ee1b8499e0 (diff)
downloadupstream-4153c0adff074167f1eb934235129471d2c04199.tar.gz
upstream-4153c0adff074167f1eb934235129471d2c04199.tar.bz2
upstream-4153c0adff074167f1eb934235129471d2c04199.zip
kernel: move mtdsplit files to drivers/mtd/mtdsplit/ to simplify maintenance, unify patches across kernel versions
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 43805
Diffstat (limited to 'target/linux/generic/patches-3.14')
-rw-r--r--target/linux/generic/patches-3.14/400-mtd-add-rootfs-split-support.patch2
-rw-r--r--target/linux/generic/patches-3.14/403-mtd-hook-mtdsplit-to-Kbuild.patch9
-rw-r--r--target/linux/generic/patches-3.14/404-mtd-add-more-helper-functions.patch (renamed from target/linux/generic/patches-3.14/405-mtd-add-more-helper-functions.patch)0
-rw-r--r--target/linux/generic/patches-3.14/405-mtd-old-firmware-uimage-splitter.patch (renamed from target/linux/generic/patches-3.14/407-mtd-old-firmware-uimage-splitter.patch)6
-rw-r--r--target/linux/generic/patches-3.14/406-mtd-hook-mtdsplit-into-Kbuild.patch24
-rw-r--r--target/linux/generic/patches-3.14/406-mtd-old-rootfs-squashfs-splitter.patch (renamed from target/linux/generic/patches-3.14/408-mtd-old-rootfs-squashfs-splitter.patch)2
-rw-r--r--target/linux/generic/patches-3.14/411-mtd-partial_eraseblock_write.patch2
-rw-r--r--target/linux/generic/patches-3.14/430-mtd-add-myloader-partition-parser.patch4
-rw-r--r--target/linux/generic/patches-3.14/431-mtd-bcm47xxpart-support-TRX-data-partition-being-UBI.patch2
-rw-r--r--target/linux/generic/patches-3.14/471-mtd-m25p80-allow-to-disable-small-sector-erase.patch2
10 files changed, 13 insertions, 40 deletions
diff --git a/target/linux/generic/patches-3.14/400-mtd-add-rootfs-split-support.patch b/target/linux/generic/patches-3.14/400-mtd-add-rootfs-split-support.patch
index 5ffacaf642..94551e247f 100644
--- a/target/linux/generic/patches-3.14/400-mtd-add-rootfs-split-support.patch
+++ b/target/linux/generic/patches-3.14/400-mtd-add-rootfs-split-support.patch
@@ -34,7 +34,7 @@
#include <linux/err.h>
#include "mtdcore.h"
-+#include "mtdsplit.h"
++#include "mtdsplit/mtdsplit.h"
/* Our partition linked list */
static LIST_HEAD(mtd_partitions);
diff --git a/target/linux/generic/patches-3.14/403-mtd-hook-mtdsplit-to-Kbuild.patch b/target/linux/generic/patches-3.14/403-mtd-hook-mtdsplit-to-Kbuild.patch
index d897034abd..0cf1c38555 100644
--- a/target/linux/generic/patches-3.14/403-mtd-hook-mtdsplit-to-Kbuild.patch
+++ b/target/linux/generic/patches-3.14/403-mtd-hook-mtdsplit-to-Kbuild.patch
@@ -1,13 +1,10 @@
--- a/drivers/mtd/Kconfig
+++ b/drivers/mtd/Kconfig
-@@ -27,6 +27,11 @@ config MTD_SPLIT_FIRMWARE_NAME
+@@ -27,6 +27,8 @@ config MTD_SPLIT_FIRMWARE_NAME
depends on MTD_SPLIT_FIRMWARE
default "firmware"
-+config MTD_SPLIT
-+ def_bool n
-+ help
-+ Generic MTD split support.
++source "drivers/mtd/mtdsplit/Kconfig"
+
endmenu
@@ -18,7 +15,7 @@
obj-$(CONFIG_MTD) += mtd.o
mtd-y := mtdcore.o mtdsuper.o mtdconcat.o mtdpart.o mtdchar.o
-+mtd-$(CONFIG_MTD_SPLIT) += mtdsplit.o
++obj-$(CONFIG_MTD_SPLIT) += mtdsplit/
+
obj-$(CONFIG_MTD_OF_PARTS) += ofpart.o
obj-$(CONFIG_MTD_REDBOOT_PARTS) += redboot.o
diff --git a/target/linux/generic/patches-3.14/405-mtd-add-more-helper-functions.patch b/target/linux/generic/patches-3.14/404-mtd-add-more-helper-functions.patch
index f3f957b33f..f3f957b33f 100644
--- a/target/linux/generic/patches-3.14/405-mtd-add-more-helper-functions.patch
+++ b/target/linux/generic/patches-3.14/404-mtd-add-more-helper-functions.patch
diff --git a/target/linux/generic/patches-3.14/407-mtd-old-firmware-uimage-splitter.patch b/target/linux/generic/patches-3.14/405-mtd-old-firmware-uimage-splitter.patch
index 3f7e910e72..c4ceb82a32 100644
--- a/target/linux/generic/patches-3.14/407-mtd-old-firmware-uimage-splitter.patch
+++ b/target/linux/generic/patches-3.14/405-mtd-old-firmware-uimage-splitter.patch
@@ -11,10 +11,10 @@
+
source "drivers/mtd/mtdsplit/Kconfig"
- config MTD_SPLIT
+ endmenu
--- a/drivers/mtd/mtdpart.c
+++ b/drivers/mtd/mtdpart.c
-@@ -668,6 +668,37 @@ mtd_pad_erasesize(struct mtd_info *mtd,
+@@ -668,6 +668,37 @@ mtd_pad_erasesize(struct mtd_info *mtd,
return len;
}
@@ -52,7 +52,7 @@
#ifdef CONFIG_MTD_SPLIT_FIRMWARE_NAME
#define SPLIT_FIRMWARE_NAME CONFIG_MTD_SPLIT_FIRMWARE_NAME
#else
-@@ -676,7 +707,14 @@ mtd_pad_erasesize(struct mtd_info *mtd,
+@@ -676,7 +707,14 @@ mtd_pad_erasesize(struct mtd_info *mtd,
static void split_firmware(struct mtd_info *master, struct mtd_part *part)
{
diff --git a/target/linux/generic/patches-3.14/406-mtd-hook-mtdsplit-into-Kbuild.patch b/target/linux/generic/patches-3.14/406-mtd-hook-mtdsplit-into-Kbuild.patch
deleted file mode 100644
index 008714bd15..0000000000
--- a/target/linux/generic/patches-3.14/406-mtd-hook-mtdsplit-into-Kbuild.patch
+++ /dev/null
@@ -1,24 +0,0 @@
---- a/drivers/mtd/Kconfig
-+++ b/drivers/mtd/Kconfig
-@@ -27,6 +27,8 @@ config MTD_SPLIT_FIRMWARE_NAME
- depends on MTD_SPLIT_FIRMWARE
- default "firmware"
-
-+source "drivers/mtd/mtdsplit/Kconfig"
-+
- config MTD_SPLIT
- def_bool n
- help
---- a/drivers/mtd/Makefile
-+++ b/drivers/mtd/Makefile
-@@ -7,6 +7,10 @@ obj-$(CONFIG_MTD) += mtd.o
- mtd-y := mtdcore.o mtdsuper.o mtdconcat.o mtdpart.o mtdchar.o
-
- mtd-$(CONFIG_MTD_SPLIT) += mtdsplit.o
-+mtd-$(CONFIG_MTD_SPLIT_SEAMA_FW) += mtdsplit_seama.o
-+mtd-$(CONFIG_MTD_SPLIT_SQUASHFS_ROOT) += mtdsplit_squashfs.o
-+mtd-$(CONFIG_MTD_SPLIT_UIMAGE_FW) += mtdsplit_uimage.o
-+mtd-$(CONFIG_MTD_SPLIT_LZMA_FW) += mtdsplit_lzma.o
-
- obj-$(CONFIG_MTD_OF_PARTS) += ofpart.o
- obj-$(CONFIG_MTD_REDBOOT_PARTS) += redboot.o
diff --git a/target/linux/generic/patches-3.14/408-mtd-old-rootfs-squashfs-splitter.patch b/target/linux/generic/patches-3.14/406-mtd-old-rootfs-squashfs-splitter.patch
index c29b137774..9147d1df46 100644
--- a/target/linux/generic/patches-3.14/408-mtd-old-rootfs-squashfs-splitter.patch
+++ b/target/linux/generic/patches-3.14/406-mtd-old-rootfs-squashfs-splitter.patch
@@ -14,7 +14,7 @@
default y
--- a/drivers/mtd/mtdpart.c
+++ b/drivers/mtd/mtdpart.c
-@@ -668,6 +668,47 @@ mtd_pad_erasesize(struct mtd_info *mtd,
+@@ -668,6 +668,47 @@ mtd_pad_erasesize(struct mtd_info *mtd,
return len;
}
diff --git a/target/linux/generic/patches-3.14/411-mtd-partial_eraseblock_write.patch b/target/linux/generic/patches-3.14/411-mtd-partial_eraseblock_write.patch
index 8da080b2ad..668b7d7289 100644
--- a/target/linux/generic/patches-3.14/411-mtd-partial_eraseblock_write.patch
+++ b/target/linux/generic/patches-3.14/411-mtd-partial_eraseblock_write.patch
@@ -2,7 +2,7 @@
+++ b/drivers/mtd/mtdpart.c
@@ -35,6 +35,8 @@
#include "mtdcore.h"
- #include "mtdsplit.h"
+ #include "mtdsplit/mtdsplit.h"
+#define MTD_ERASE_PARTIAL 0x8000 /* partition only covers parts of an erase block */
+
diff --git a/target/linux/generic/patches-3.14/430-mtd-add-myloader-partition-parser.patch b/target/linux/generic/patches-3.14/430-mtd-add-myloader-partition-parser.patch
index ffc9e2199c..45af25dd61 100644
--- a/target/linux/generic/patches-3.14/430-mtd-add-myloader-partition-parser.patch
+++ b/target/linux/generic/patches-3.14/430-mtd-add-myloader-partition-parser.patch
@@ -1,6 +1,6 @@
--- a/drivers/mtd/Kconfig
+++ b/drivers/mtd/Kconfig
-@@ -189,6 +189,22 @@ config MTD_BCM47XX_PARTS
+@@ -184,6 +184,22 @@ config MTD_BCM47XX_PARTS
This provides partitions parser for devices based on BCM47xx
boards.
@@ -25,7 +25,7 @@
#
--- a/drivers/mtd/Makefile
+++ b/drivers/mtd/Makefile
-@@ -19,6 +19,7 @@ obj-$(CONFIG_MTD_AFS_PARTS) += afs.o
+@@ -15,6 +15,7 @@ obj-$(CONFIG_MTD_AFS_PARTS) += afs.o
obj-$(CONFIG_MTD_AR7_PARTS) += ar7part.o
obj-$(CONFIG_MTD_BCM63XX_PARTS) += bcm63xxpart.o
obj-$(CONFIG_MTD_BCM47XX_PARTS) += bcm47xxpart.o
diff --git a/target/linux/generic/patches-3.14/431-mtd-bcm47xxpart-support-TRX-data-partition-being-UBI.patch b/target/linux/generic/patches-3.14/431-mtd-bcm47xxpart-support-TRX-data-partition-being-UBI.patch
index 4c4720341e..46881fca2c 100644
--- a/target/linux/generic/patches-3.14/431-mtd-bcm47xxpart-support-TRX-data-partition-being-UBI.patch
+++ b/target/linux/generic/patches-3.14/431-mtd-bcm47xxpart-support-TRX-data-partition-being-UBI.patch
@@ -17,7 +17,7 @@
u64 offset, uint32_t mask_flags)
{
part->name = name;
-@@ -58,6 +59,26 @@ static void bcm47xxpart_add_part(struct
+@@ -58,6 +59,26 @@ static void bcm47xxpart_add_part(struct
part->mask_flags = mask_flags;
}
diff --git a/target/linux/generic/patches-3.14/471-mtd-m25p80-allow-to-disable-small-sector-erase.patch b/target/linux/generic/patches-3.14/471-mtd-m25p80-allow-to-disable-small-sector-erase.patch
index eec90fa413..4f2f4e6586 100644
--- a/target/linux/generic/patches-3.14/471-mtd-m25p80-allow-to-disable-small-sector-erase.patch
+++ b/target/linux/generic/patches-3.14/471-mtd-m25p80-allow-to-disable-small-sector-erase.patch
@@ -30,7 +30,7 @@
/****************************************************************************/
enum read_type {
-@@ -1192,7 +1198,7 @@ static int m25p_probe(struct spi_device
+@@ -1192,7 +1198,7 @@ static int m25p_probe(struct spi_device
flash->mtd._write = m25p80_write;
/* prefer "small sector" erase if possible */