aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.14/726-phy_rtl8366.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2014-03-07 11:27:00 +0000
committerImre Kaloz <kaloz@openwrt.org>2014-03-07 11:27:00 +0000
commit074af75668dd491042b07a26059927da38f13663 (patch)
tree58362fbaa56de52bda6c4aafc825d5bf5c40ec09 /target/linux/generic/patches-3.14/726-phy_rtl8366.patch
parent96fa58bafd6b311a9a3686b704bf8074905c4bea (diff)
downloadupstream-074af75668dd491042b07a26059927da38f13663.tar.gz
upstream-074af75668dd491042b07a26059927da38f13663.tar.bz2
upstream-074af75668dd491042b07a26059927da38f13663.zip
add preliminary 3.14 support
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> SVN-Revision: 39789
Diffstat (limited to 'target/linux/generic/patches-3.14/726-phy_rtl8366.patch')
-rw-r--r--target/linux/generic/patches-3.14/726-phy_rtl8366.patch45
1 files changed, 45 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.14/726-phy_rtl8366.patch b/target/linux/generic/patches-3.14/726-phy_rtl8366.patch
new file mode 100644
index 0000000000..52ef6108dc
--- /dev/null
+++ b/target/linux/generic/patches-3.14/726-phy_rtl8366.patch
@@ -0,0 +1,45 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -231,6 +231,30 @@ config MDIO_BUS_MUX_MMIOREG
+
+ Currently, only 8-bit registers are supported.
+
++config RTL8366_SMI
++ tristate "Driver for the RTL8366 SMI interface"
++ depends on GPIOLIB
++ ---help---
++ This module implements the SMI interface protocol which is used
++ by some RTL8366 ethernet switch devices via the generic GPIO API.
++
++if RTL8366_SMI
++
++config RTL8366_SMI_DEBUG_FS
++ bool "RTL8366 SMI interface debugfs support"
++ depends on DEBUG_FS
++ default n
++
++config RTL8366S_PHY
++ tristate "Driver for the Realtek RTL8366S switch"
++ select SWCONFIG
++
++config RTL8366RB_PHY
++ tristate "Driver for the Realtek RTL8366RB switch"
++ select SWCONFIG
++
++endif # RTL8366_SMI
++
+ endif # PHYLIB
+
+ config MICREL_KS8995MA
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -23,6 +23,9 @@ obj-$(CONFIG_IP17XX_PHY) += ip17xx.o
+ obj-$(CONFIG_REALTEK_PHY) += realtek.o
+ obj-$(CONFIG_AR8216_PHY) += ar8216.o
+ obj-$(CONFIG_RTL8306_PHY) += rtl8306.o
++obj-$(CONFIG_RTL8366_SMI) += rtl8366_smi.o
++obj-$(CONFIG_RTL8366S_PHY) += rtl8366s.o
++obj-$(CONFIG_RTL8366RB_PHY) += rtl8366rb.o
+ obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
+ obj-$(CONFIG_FIXED_PHY) += fixed.o
+ obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o