aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.13/970-remove-unsane-filenames-from-deps_initramfs-list.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2014-01-20 13:56:24 +0000
committerImre Kaloz <kaloz@openwrt.org>2014-01-20 13:56:24 +0000
commit6bd1a3700191f14d64c417a1e443ec035a4efee7 (patch)
tree2c3d28386bbc47c37b708c0937962caae6a5ffa9 /target/linux/generic/patches-3.13/970-remove-unsane-filenames-from-deps_initramfs-list.patch
parentc67ec51c85184c4fb3b6cf13f6ffc1e810ecdc6f (diff)
downloadupstream-6bd1a3700191f14d64c417a1e443ec035a4efee7.tar.gz
upstream-6bd1a3700191f14d64c417a1e443ec035a4efee7.tar.bz2
upstream-6bd1a3700191f14d64c417a1e443ec035a4efee7.zip
add initial 3.13 support
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> SVN-Revision: 39348
Diffstat (limited to 'target/linux/generic/patches-3.13/970-remove-unsane-filenames-from-deps_initramfs-list.patch')
-rw-r--r--target/linux/generic/patches-3.13/970-remove-unsane-filenames-from-deps_initramfs-list.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.13/970-remove-unsane-filenames-from-deps_initramfs-list.patch b/target/linux/generic/patches-3.13/970-remove-unsane-filenames-from-deps_initramfs-list.patch
new file mode 100644
index 0000000000..ac13c9e673
--- /dev/null
+++ b/target/linux/generic/patches-3.13/970-remove-unsane-filenames-from-deps_initramfs-list.patch
@@ -0,0 +1,29 @@
+--- a/usr/Makefile
++++ b/usr/Makefile
+@@ -53,6 +53,8 @@ ifneq ($(wildcard $(obj)/.initramfs_data
+ include $(obj)/.initramfs_data.cpio.d
+ endif
+
++deps_initramfs_sane := $(foreach v,$(deps_initramfs),$(if $(findstring :,$(v)),,$(v)))
++
+ quiet_cmd_initfs = GEN $@
+ cmd_initfs = $(initramfs) -o $@ $(ramfs-args) $(ramfs-input)
+
+@@ -61,14 +63,14 @@ targets := initramfs_data.cpio.gz initra
+ initramfs_data.cpio.lzo initramfs_data.cpio.lz4 \
+ initramfs_data.cpio
+ # do not try to update files included in initramfs
+-$(deps_initramfs): ;
++$(deps_initramfs_sane): ;
+
+-$(deps_initramfs): klibcdirs
++$(deps_initramfs_sane): klibcdirs
+ # We rebuild initramfs_data.cpio if:
+ # 1) Any included file is newer then initramfs_data.cpio
+ # 2) There are changes in which files are included (added or deleted)
+ # 3) If gen_init_cpio are newer than initramfs_data.cpio
+ # 4) arguments to gen_initramfs.sh changes
+-$(obj)/initramfs_data.cpio$(suffix_y): $(obj)/gen_init_cpio $(deps_initramfs) klibcdirs
++$(obj)/initramfs_data.cpio$(suffix_y): $(obj)/gen_init_cpio $(deps_initramfs_sane) klibcdirs
+ $(Q)$(initramfs) -l $(ramfs-input) > $(obj)/.initramfs_data.cpio.d
+ $(call if_changed,initfs)