aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.13/940-ocf_kbuild_integration.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2014-01-20 13:56:24 +0000
committerImre Kaloz <kaloz@openwrt.org>2014-01-20 13:56:24 +0000
commit6bd1a3700191f14d64c417a1e443ec035a4efee7 (patch)
tree2c3d28386bbc47c37b708c0937962caae6a5ffa9 /target/linux/generic/patches-3.13/940-ocf_kbuild_integration.patch
parentc67ec51c85184c4fb3b6cf13f6ffc1e810ecdc6f (diff)
downloadupstream-6bd1a3700191f14d64c417a1e443ec035a4efee7.tar.gz
upstream-6bd1a3700191f14d64c417a1e443ec035a4efee7.tar.bz2
upstream-6bd1a3700191f14d64c417a1e443ec035a4efee7.zip
add initial 3.13 support
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> SVN-Revision: 39348
Diffstat (limited to 'target/linux/generic/patches-3.13/940-ocf_kbuild_integration.patch')
-rw-r--r--target/linux/generic/patches-3.13/940-ocf_kbuild_integration.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.13/940-ocf_kbuild_integration.patch b/target/linux/generic/patches-3.13/940-ocf_kbuild_integration.patch
new file mode 100644
index 0000000000..7ad92374d8
--- /dev/null
+++ b/target/linux/generic/patches-3.13/940-ocf_kbuild_integration.patch
@@ -0,0 +1,20 @@
+--- a/crypto/Kconfig
++++ b/crypto/Kconfig
+@@ -1415,3 +1415,6 @@ source "drivers/crypto/Kconfig"
+ source crypto/asymmetric_keys/Kconfig
+
+ endif # if CRYPTO
++
++source "crypto/ocf/Kconfig"
++
+--- a/crypto/Makefile
++++ b/crypto/Makefile
+@@ -104,6 +104,8 @@ obj-$(CONFIG_CRYPTO_USER_API) += af_alg.
+ obj-$(CONFIG_CRYPTO_USER_API_HASH) += algif_hash.o
+ obj-$(CONFIG_CRYPTO_USER_API_SKCIPHER) += algif_skcipher.o
+
++obj-$(CONFIG_OCF_OCF) += ocf/
++
+ #
+ # generic algorithms and the async_tx api
+ #