aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.13/730-phy_b53.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2014-01-20 13:56:24 +0000
committerImre Kaloz <kaloz@openwrt.org>2014-01-20 13:56:24 +0000
commit11d25cc460a75454a9aa8d3a7c70abb5abcf8d2c (patch)
treeec4fe2ab7f765c6d86d6b321349f296dbc9afb9b /target/linux/generic/patches-3.13/730-phy_b53.patch
parent54d11602cc5a312834e38e09158ac55cc3429a86 (diff)
downloadupstream-11d25cc460a75454a9aa8d3a7c70abb5abcf8d2c.tar.gz
upstream-11d25cc460a75454a9aa8d3a7c70abb5abcf8d2c.tar.bz2
upstream-11d25cc460a75454a9aa8d3a7c70abb5abcf8d2c.zip
[generic]: add initial 3.13 support
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39348 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-3.13/730-phy_b53.patch')
-rw-r--r--target/linux/generic/patches-3.13/730-phy_b53.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.13/730-phy_b53.patch b/target/linux/generic/patches-3.13/730-phy_b53.patch
new file mode 100644
index 0000000000..cd58182f7e
--- /dev/null
+++ b/target/linux/generic/patches-3.13/730-phy_b53.patch
@@ -0,0 +1,21 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -268,6 +268,8 @@ config RTL8367B_PHY
+
+ endif # RTL8366_SMI
+
++source "drivers/net/phy/b53/Kconfig"
++
+ endif # PHYLIB
+
+ config MICREL_KS8995MA
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -31,6 +31,7 @@ obj-$(CONFIG_RTL8367B_PHY) += rtl8367b.o
+ obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
+ obj-$(CONFIG_MICREL_PHY) += micrel.o
+ obj-$(CONFIG_PSB6970_PHY) += psb6970.o
++obj-$(CONFIG_B53) += b53/
+ obj-$(CONFIG_FIXED_PHY) += fixed.o
+ obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o
+ obj-$(CONFIG_MDIO_GPIO) += mdio-gpio.o