aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.13/726-phy_rtl8366.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-03-16 05:52:02 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-03-16 05:52:02 +0000
commit171313998e419d84172068f1be9cdeb90fdd192e (patch)
treeeec8e974d8331b7607aed5acf87a948445dc328f /target/linux/generic/patches-3.13/726-phy_rtl8366.patch
parent16a075391921e7a2dcd9f3cbba91f468176c3601 (diff)
downloadupstream-171313998e419d84172068f1be9cdeb90fdd192e.tar.gz
upstream-171313998e419d84172068f1be9cdeb90fdd192e.tar.bz2
upstream-171313998e419d84172068f1be9cdeb90fdd192e.zip
kernel: remove linux 3.13 support
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44804 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-3.13/726-phy_rtl8366.patch')
-rw-r--r--target/linux/generic/patches-3.13/726-phy_rtl8366.patch45
1 files changed, 0 insertions, 45 deletions
diff --git a/target/linux/generic/patches-3.13/726-phy_rtl8366.patch b/target/linux/generic/patches-3.13/726-phy_rtl8366.patch
deleted file mode 100644
index 60efd822ff..0000000000
--- a/target/linux/generic/patches-3.13/726-phy_rtl8366.patch
+++ /dev/null
@@ -1,45 +0,0 @@
---- a/drivers/net/phy/Kconfig
-+++ b/drivers/net/phy/Kconfig
-@@ -231,6 +231,30 @@ config MDIO_BUS_MUX_MMIOREG
-
- Currently, only 8-bit registers are supported.
-
-+config RTL8366_SMI
-+ tristate "Driver for the RTL8366 SMI interface"
-+ depends on GPIOLIB
-+ ---help---
-+ This module implements the SMI interface protocol which is used
-+ by some RTL8366 ethernet switch devices via the generic GPIO API.
-+
-+if RTL8366_SMI
-+
-+config RTL8366_SMI_DEBUG_FS
-+ bool "RTL8366 SMI interface debugfs support"
-+ depends on DEBUG_FS
-+ default n
-+
-+config RTL8366S_PHY
-+ tristate "Driver for the Realtek RTL8366S switch"
-+ select SWCONFIG
-+
-+config RTL8366RB_PHY
-+ tristate "Driver for the Realtek RTL8366RB switch"
-+ select SWCONFIG
-+
-+endif # RTL8366_SMI
-+
- endif # PHYLIB
-
- config MICREL_KS8995MA
---- a/drivers/net/phy/Makefile
-+++ b/drivers/net/phy/Makefile
-@@ -23,6 +23,9 @@ obj-$(CONFIG_IP17XX_PHY) += ip17xx.o
- obj-$(CONFIG_REALTEK_PHY) += realtek.o
- obj-$(CONFIG_AR8216_PHY) += ar8216.o ar8327.o
- obj-$(CONFIG_RTL8306_PHY) += rtl8306.o
-+obj-$(CONFIG_RTL8366_SMI) += rtl8366_smi.o
-+obj-$(CONFIG_RTL8366S_PHY) += rtl8366s.o
-+obj-$(CONFIG_RTL8366RB_PHY) += rtl8366rb.o
- obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
- obj-$(CONFIG_FIXED_PHY) += fixed.o
- obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o