aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.12/727-phy-rtl8367.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2013-10-24 13:50:11 +0000
committerImre Kaloz <kaloz@openwrt.org>2013-10-24 13:50:11 +0000
commite72c7e17a475c00134c56f4392578ddc16a47a2e (patch)
tree842835f958f9c9ed315cb853173d51e43f76bbf5 /target/linux/generic/patches-3.12/727-phy-rtl8367.patch
parent4341ea40379ed24c103e37b75661c62bfc3270f6 (diff)
downloadupstream-e72c7e17a475c00134c56f4392578ddc16a47a2e.tar.gz
upstream-e72c7e17a475c00134c56f4392578ddc16a47a2e.tar.bz2
upstream-e72c7e17a475c00134c56f4392578ddc16a47a2e.zip
preliminary 3.12 support
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> SVN-Revision: 38528
Diffstat (limited to 'target/linux/generic/patches-3.12/727-phy-rtl8367.patch')
-rw-r--r--target/linux/generic/patches-3.12/727-phy-rtl8367.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.12/727-phy-rtl8367.patch b/target/linux/generic/patches-3.12/727-phy-rtl8367.patch
new file mode 100644
index 0000000000..025efc3222
--- /dev/null
+++ b/target/linux/generic/patches-3.12/727-phy-rtl8367.patch
@@ -0,0 +1,23 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -246,6 +246,10 @@ config RTL8366RB_PHY
+ tristate "Driver for the Realtek RTL8366RB switch"
+ select SWCONFIG
+
++config RTL8367_PHY
++ tristate "Driver for the Realtek RTL8367R/M switches"
++ select SWCONFIG
++
+ endif # RTL8366_SMI
+
+ endif # PHYLIB
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -26,6 +26,7 @@ obj-$(CONFIG_RTL8306_PHY) += rtl8306.o
+ obj-$(CONFIG_RTL8366_SMI) += rtl8366_smi.o
+ obj-$(CONFIG_RTL8366S_PHY) += rtl8366s.o
+ obj-$(CONFIG_RTL8366RB_PHY) += rtl8366rb.o
++obj-$(CONFIG_RTL8367_PHY) += rtl8367.o
+ obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
+ obj-$(CONFIG_FIXED_PHY) += fixed.o
+ obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o