aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.12/500-yaffs-Kbuild-integration.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2013-10-24 13:50:11 +0000
committerImre Kaloz <kaloz@openwrt.org>2013-10-24 13:50:11 +0000
commite72c7e17a475c00134c56f4392578ddc16a47a2e (patch)
tree842835f958f9c9ed315cb853173d51e43f76bbf5 /target/linux/generic/patches-3.12/500-yaffs-Kbuild-integration.patch
parent4341ea40379ed24c103e37b75661c62bfc3270f6 (diff)
downloadupstream-e72c7e17a475c00134c56f4392578ddc16a47a2e.tar.gz
upstream-e72c7e17a475c00134c56f4392578ddc16a47a2e.tar.bz2
upstream-e72c7e17a475c00134c56f4392578ddc16a47a2e.zip
preliminary 3.12 support
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> SVN-Revision: 38528
Diffstat (limited to 'target/linux/generic/patches-3.12/500-yaffs-Kbuild-integration.patch')
-rw-r--r--target/linux/generic/patches-3.12/500-yaffs-Kbuild-integration.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.12/500-yaffs-Kbuild-integration.patch b/target/linux/generic/patches-3.12/500-yaffs-Kbuild-integration.patch
new file mode 100644
index 0000000000..3742e54121
--- /dev/null
+++ b/target/linux/generic/patches-3.12/500-yaffs-Kbuild-integration.patch
@@ -0,0 +1,18 @@
+--- a/fs/Kconfig
++++ b/fs/Kconfig
+@@ -39,6 +39,7 @@ source "fs/gfs2/Kconfig"
+ source "fs/ocfs2/Kconfig"
+ source "fs/btrfs/Kconfig"
+ source "fs/nilfs2/Kconfig"
++source "fs/yaffs2/Kconfig"
+
+ endif # BLOCK
+
+--- a/fs/Makefile
++++ b/fs/Makefile
+@@ -127,3 +127,5 @@ obj-y += exofs/ # Multiple modules
+ obj-$(CONFIG_CEPH_FS) += ceph/
+ obj-$(CONFIG_PSTORE) += pstore/
+ obj-$(CONFIG_EFIVAR_FS) += efivarfs/
++obj-$(CONFIG_YAFFS_FS) += yaffs2/
++