aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.12/201-extra_optimization.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2013-10-24 13:50:11 +0000
committerImre Kaloz <kaloz@openwrt.org>2013-10-24 13:50:11 +0000
commitbdc2e671912c3737ec65454cc7a5ed91213f7e01 (patch)
tree4613cca2c570d5eefc520620ba3bac85f7015a4b /target/linux/generic/patches-3.12/201-extra_optimization.patch
parentbf6998b89de06eae7f3fb8cecd43482d6cb15afb (diff)
downloadupstream-bdc2e671912c3737ec65454cc7a5ed91213f7e01.tar.gz
upstream-bdc2e671912c3737ec65454cc7a5ed91213f7e01.tar.bz2
upstream-bdc2e671912c3737ec65454cc7a5ed91213f7e01.zip
[generic:] preliminary 3.12 support
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38528 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-3.12/201-extra_optimization.patch')
-rw-r--r--target/linux/generic/patches-3.12/201-extra_optimization.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.12/201-extra_optimization.patch b/target/linux/generic/patches-3.12/201-extra_optimization.patch
new file mode 100644
index 0000000000..ccb7fcfb3b
--- /dev/null
+++ b/target/linux/generic/patches-3.12/201-extra_optimization.patch
@@ -0,0 +1,14 @@
+--- a/Makefile
++++ b/Makefile
+@@ -571,9 +571,9 @@ endif # $(dot-config)
+ all: vmlinux
+
+ ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
+-KBUILD_CFLAGS += -Os $(call cc-disable-warning,maybe-uninitialized,)
++KBUILD_CFLAGS += -Os $(EXTRA_OPTIMIZATION) $(call cc-disable-warning,maybe-uninitialized,)
+ else
+-KBUILD_CFLAGS += -O2
++KBUILD_CFLAGS += -O2 -fno-reorder-blocks -fno-tree-ch $(EXTRA_OPTIMIZATION)
+ endif
+
+ include $(srctree)/arch/$(SRCARCH)/Makefile