aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.1/726-phy_rtl8366.patch
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2011-08-09 12:19:43 +0000
committerJonas Gorski <jogo@openwrt.org>2011-08-09 12:19:43 +0000
commitcf2070bd5b394d5c3fcfae577bd623a6e8a7f0c4 (patch)
treef0d9e62c746434dde7a45ed0debd3eb94b92dc65 /target/linux/generic/patches-3.1/726-phy_rtl8366.patch
parenta5f2fd63598414246a497e08a4433a0116f2f606 (diff)
downloadupstream-cf2070bd5b394d5c3fcfae577bd623a6e8a7f0c4.tar.gz
upstream-cf2070bd5b394d5c3fcfae577bd623a6e8a7f0c4.tar.bz2
upstream-cf2070bd5b394d5c3fcfae577bd623a6e8a7f0c4.zip
linux: generic: add support for 3.1-rc1
SVN-Revision: 27940
Diffstat (limited to 'target/linux/generic/patches-3.1/726-phy_rtl8366.patch')
-rw-r--r--target/linux/generic/patches-3.1/726-phy_rtl8366.patch44
1 files changed, 44 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.1/726-phy_rtl8366.patch b/target/linux/generic/patches-3.1/726-phy_rtl8366.patch
new file mode 100644
index 0000000000..badc0a4e62
--- /dev/null
+++ b/target/linux/generic/patches-3.1/726-phy_rtl8366.patch
@@ -0,0 +1,44 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -158,4 +158,29 @@ config MDIO_OCTEON
+
+ If in doubt, say Y.
+
++config RTL8366_SMI
++ tristate "Driver for the RTL8366 SMI interface"
++ depends on GENERIC_GPIO
++ ---help---
++ This module implements the SMI interface protocol which is used
++ by some RTL8366 ethernet switch devices via the generic GPIO API.
++
++if RTL8366_SMI
++
++config RTL8366S_PHY
++ tristate "Driver for the Realtek RTL8366S switch"
++ select SWCONFIG
++
++config RTL8366RB_PHY
++ tristate "Driver for the Realtek RTL8366RB switch"
++ select SWCONFIG
++
++config RTL8366S_PHY_DEBUG_FS
++ bool "RTL8366 switch driver DEBUG_FS support"
++ depends on RTL8366S_PHY || RTL8366RB_PHY
++ depends on DEBUG_FS
++ default n
++
++endif # RTL8366_SMI
++
+ endif # PHYLIB
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -20,6 +20,9 @@ obj-$(CONFIG_IP17XX_PHY) += ip17xx.o
+ obj-$(CONFIG_REALTEK_PHY) += realtek.o
+ obj-$(CONFIG_AR8216_PHY) += ar8216.o
+ obj-$(CONFIG_RTL8306_PHY) += rtl8306.o
++obj-$(CONFIG_RTL8366_SMI) += rtl8366_smi.o
++obj-$(CONFIG_RTL8366S_PHY) += rtl8366s.o
++obj-$(CONFIG_RTL8366RB_PHY) += rtl8366rb.o
+ obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
+ obj-$(CONFIG_FIXED_PHY) += fixed.o
+ obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o