aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.1/722-phy_mvswitch.patch
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2011-08-09 12:19:43 +0000
committerJonas Gorski <jogo@openwrt.org>2011-08-09 12:19:43 +0000
commitcf2070bd5b394d5c3fcfae577bd623a6e8a7f0c4 (patch)
treef0d9e62c746434dde7a45ed0debd3eb94b92dc65 /target/linux/generic/patches-3.1/722-phy_mvswitch.patch
parenta5f2fd63598414246a497e08a4433a0116f2f606 (diff)
downloadupstream-cf2070bd5b394d5c3fcfae577bd623a6e8a7f0c4.tar.gz
upstream-cf2070bd5b394d5c3fcfae577bd623a6e8a7f0c4.tar.bz2
upstream-cf2070bd5b394d5c3fcfae577bd623a6e8a7f0c4.zip
linux: generic: add support for 3.1-rc1
SVN-Revision: 27940
Diffstat (limited to 'target/linux/generic/patches-3.1/722-phy_mvswitch.patch')
-rw-r--r--target/linux/generic/patches-3.1/722-phy_mvswitch.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.1/722-phy_mvswitch.patch b/target/linux/generic/patches-3.1/722-phy_mvswitch.patch
new file mode 100644
index 0000000000..2025b229a4
--- /dev/null
+++ b/target/linux/generic/patches-3.1/722-phy_mvswitch.patch
@@ -0,0 +1,22 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -105,6 +105,9 @@ config ADM6996_PHY
+ Currently supports the ADM6996FC and ADM6996M switches.
+ Support for FC is very limited.
+
++config MVSWITCH_PHY
++ tristate "Driver for Marvell 88E6060 switches"
++
+ config FIXED_PHY
+ bool "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
+ depends on PHYLIB=y
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -15,6 +15,7 @@ obj-$(CONFIG_BROADCOM_PHY) += broadcom.o
+ obj-$(CONFIG_BCM63XX_PHY) += bcm63xx.o
+ obj-$(CONFIG_ICPLUS_PHY) += icplus.o
+ obj-$(CONFIG_ADM6996_PHY) += adm6996.o
++obj-$(CONFIG_MVSWITCH_PHY) += mvswitch.o
+ obj-$(CONFIG_REALTEK_PHY) += realtek.o
+ obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
+ obj-$(CONFIG_FIXED_PHY) += fixed.o