aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.1/201-extra_optimization.patch
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2011-08-09 12:19:43 +0000
committerJonas Gorski <jogo@openwrt.org>2011-08-09 12:19:43 +0000
commitf8c7d2d540cb3ef04ea077a54ab40032f2a50976 (patch)
treecc4ae0400759c09d1eb08510f89711899bf63bce /target/linux/generic/patches-3.1/201-extra_optimization.patch
parentc025c5e99da524b1bb8fc9bdf00836f4e7402d96 (diff)
downloadupstream-f8c7d2d540cb3ef04ea077a54ab40032f2a50976.tar.gz
upstream-f8c7d2d540cb3ef04ea077a54ab40032f2a50976.tar.bz2
upstream-f8c7d2d540cb3ef04ea077a54ab40032f2a50976.zip
linux: generic: add support for 3.1-rc1
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@27940 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-3.1/201-extra_optimization.patch')
-rw-r--r--target/linux/generic/patches-3.1/201-extra_optimization.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.1/201-extra_optimization.patch b/target/linux/generic/patches-3.1/201-extra_optimization.patch
new file mode 100644
index 0000000000..6fe8b0938d
--- /dev/null
+++ b/target/linux/generic/patches-3.1/201-extra_optimization.patch
@@ -0,0 +1,24 @@
+--- a/Makefile
++++ b/Makefile
+@@ -559,9 +559,9 @@ endif # $(dot-config)
+ all: vmlinux
+
+ ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
+-KBUILD_CFLAGS += -Os
++KBUILD_CFLAGS += -Os -fno-caller-saves
+ else
+-KBUILD_CFLAGS += -O2
++KBUILD_CFLAGS += -O2 -fno-reorder-blocks -fno-tree-ch -fno-caller-saves
+ endif
+
+ include $(srctree)/arch/$(SRCARCH)/Makefile
+@@ -620,6 +620,9 @@ endif
+ NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
+ CHECKFLAGS += $(NOSTDINC_FLAGS)
+
++# improve gcc optimization
++CFLAGS += $(call cc-option,-funit-at-a-time,)
++
+ # warn about C99 declaration after statement
+ KBUILD_CFLAGS += $(call cc-option,-Wdeclaration-after-statement,)
+