aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.1/201-extra_optimization.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-05-27 15:01:09 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-05-27 15:01:09 +0000
commitde4c4d35e17830170dba6aa1b3b025d93a7b3302 (patch)
treec57b3c28c8453826a6abcef3f83b80d72f732253 /target/linux/generic/patches-3.1/201-extra_optimization.patch
parentcead4b47abdebcb8506451b4a3e30028982161a1 (diff)
downloadupstream-de4c4d35e17830170dba6aa1b3b025d93a7b3302.tar.gz
upstream-de4c4d35e17830170dba6aa1b3b025d93a7b3302.tar.bz2
upstream-de4c4d35e17830170dba6aa1b3b025d93a7b3302.zip
linux/3.1: R.I.P.
SVN-Revision: 31891
Diffstat (limited to 'target/linux/generic/patches-3.1/201-extra_optimization.patch')
-rw-r--r--target/linux/generic/patches-3.1/201-extra_optimization.patch24
1 files changed, 0 insertions, 24 deletions
diff --git a/target/linux/generic/patches-3.1/201-extra_optimization.patch b/target/linux/generic/patches-3.1/201-extra_optimization.patch
deleted file mode 100644
index 6fe8b0938d..0000000000
--- a/target/linux/generic/patches-3.1/201-extra_optimization.patch
+++ /dev/null
@@ -1,24 +0,0 @@
---- a/Makefile
-+++ b/Makefile
-@@ -559,9 +559,9 @@ endif # $(dot-config)
- all: vmlinux
-
- ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
--KBUILD_CFLAGS += -Os
-+KBUILD_CFLAGS += -Os -fno-caller-saves
- else
--KBUILD_CFLAGS += -O2
-+KBUILD_CFLAGS += -O2 -fno-reorder-blocks -fno-tree-ch -fno-caller-saves
- endif
-
- include $(srctree)/arch/$(SRCARCH)/Makefile
-@@ -620,6 +620,9 @@ endif
- NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
- CHECKFLAGS += $(NOSTDINC_FLAGS)
-
-+# improve gcc optimization
-+CFLAGS += $(call cc-option,-funit-at-a-time,)
-+
- # warn about C99 declaration after statement
- KBUILD_CFLAGS += $(call cc-option,-Wdeclaration-after-statement,)
-