aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.0/700-swconfig.patch
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2011-06-15 21:31:01 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2011-06-15 21:31:01 +0000
commit235e3319876d5d1354e2774ec73495fdeb2616ec (patch)
treed776ac5daed14d9e6ee5562e979d388420e8ff08 /target/linux/generic/patches-3.0/700-swconfig.patch
parent0db9c2bd7d3620ba18fa784bda702d971783b4f6 (diff)
downloadupstream-235e3319876d5d1354e2774ec73495fdeb2616ec.tar.gz
upstream-235e3319876d5d1354e2774ec73495fdeb2616ec.tar.bz2
upstream-235e3319876d5d1354e2774ec73495fdeb2616ec.zip
linux/generic: Add support for 3.0-rc3
Also make linux identify itself properly as 3.0, not 3.0.0. Signed-off-by: Jonas Gorski <jonas.gorski+openwrt@gmail.com> SVN-Revision: 27191
Diffstat (limited to 'target/linux/generic/patches-3.0/700-swconfig.patch')
-rw-r--r--target/linux/generic/patches-3.0/700-swconfig.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.0/700-swconfig.patch b/target/linux/generic/patches-3.0/700-swconfig.patch
new file mode 100644
index 0000000000..6825037ce9
--- /dev/null
+++ b/target/linux/generic/patches-3.0/700-swconfig.patch
@@ -0,0 +1,25 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -13,6 +13,12 @@ menuconfig PHYLIB
+
+ if PHYLIB
+
++config SWCONFIG
++ tristate "Switch configuration API"
++ ---help---
++ Switch configuration API using netlink. This allows
++ you to configure the VLAN features of certain switches.
++
+ comment "MII PHY device drivers"
+
+ config MARVELL_PHY
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -3,6 +3,7 @@
+ libphy-objs := phy.o phy_device.o mdio_bus.o
+
+ obj-$(CONFIG_PHYLIB) += libphy.o
++obj-$(CONFIG_SWCONFIG) += swconfig.o
+ obj-$(CONFIG_MARVELL_PHY) += marvell.o
+ obj-$(CONFIG_DAVICOM_PHY) += davicom.o
+ obj-$(CONFIG_CICADA_PHY) += cicada.o