aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-2.6.39/940-ocf_kbuild_integration.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2011-04-16 18:31:05 +0000
committerFelix Fietkau <nbd@openwrt.org>2011-04-16 18:31:05 +0000
commit3fa43f54a267f45e42be641945573450a0a419b8 (patch)
treeafa65eace467c96d7b49262ac89892f8d8f977b6 /target/linux/generic/patches-2.6.39/940-ocf_kbuild_integration.patch
parent71d8c66250eef1806d680a27d175c61dd9971a5e (diff)
downloadupstream-3fa43f54a267f45e42be641945573450a0a419b8.tar.gz
upstream-3fa43f54a267f45e42be641945573450a0a419b8.tar.bz2
upstream-3fa43f54a267f45e42be641945573450a0a419b8.zip
kernel: reorganize 2.6.39 patches
SVN-Revision: 26691
Diffstat (limited to 'target/linux/generic/patches-2.6.39/940-ocf_kbuild_integration.patch')
-rw-r--r--target/linux/generic/patches-2.6.39/940-ocf_kbuild_integration.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/generic/patches-2.6.39/940-ocf_kbuild_integration.patch b/target/linux/generic/patches-2.6.39/940-ocf_kbuild_integration.patch
new file mode 100644
index 0000000000..3c322f3d14
--- /dev/null
+++ b/target/linux/generic/patches-2.6.39/940-ocf_kbuild_integration.patch
@@ -0,0 +1,20 @@
+--- a/crypto/Kconfig
++++ b/crypto/Kconfig
+@@ -866,3 +866,6 @@ config CRYPTO_USER_API_SKCIPHER
+ source "drivers/crypto/Kconfig"
+
+ endif # if CRYPTO
++
++source "crypto/ocf/Kconfig"
++
+--- a/crypto/Makefile
++++ b/crypto/Makefile
+@@ -89,6 +89,8 @@ obj-$(CONFIG_CRYPTO_USER_API) += af_alg.
+ obj-$(CONFIG_CRYPTO_USER_API_HASH) += algif_hash.o
+ obj-$(CONFIG_CRYPTO_USER_API_SKCIPHER) += algif_skcipher.o
+
++obj-$(CONFIG_OCF_OCF) += ocf/
++
+ #
+ # generic algorithms and the async_tx api
+ #