aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-2.6.39/690-phy_rtl8306.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2011-04-12 19:39:20 +0000
committerFelix Fietkau <nbd@openwrt.org>2011-04-12 19:39:20 +0000
commit127e4ebd32d51070fd5763e4d50aba211b02de6a (patch)
tree510a31b05cfa6ae4477fd738371cc12d3df27853 /target/linux/generic/patches-2.6.39/690-phy_rtl8306.patch
parent512bb389ee6125135c6da818686f98774191b457 (diff)
downloadupstream-127e4ebd32d51070fd5763e4d50aba211b02de6a.tar.gz
upstream-127e4ebd32d51070fd5763e4d50aba211b02de6a.tar.bz2
upstream-127e4ebd32d51070fd5763e4d50aba211b02de6a.zip
generic: Add support for 2.6.39
Add support for 2.6.39 based on rc3. Runtime tested on bcm63xx. SVN-Revision: 26615
Diffstat (limited to 'target/linux/generic/patches-2.6.39/690-phy_rtl8306.patch')
-rw-r--r--target/linux/generic/patches-2.6.39/690-phy_rtl8306.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/generic/patches-2.6.39/690-phy_rtl8306.patch b/target/linux/generic/patches-2.6.39/690-phy_rtl8306.patch
new file mode 100644
index 0000000000..cd5e1a88b2
--- /dev/null
+++ b/target/linux/generic/patches-2.6.39/690-phy_rtl8306.patch
@@ -0,0 +1,23 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -113,6 +113,10 @@ config AR8216_PHY
+ tristate "Driver for Atheros AR8216 switches"
+ select SWCONFIG
+
++config RTL8306_PHY
++ tristate "Driver for Realtek RTL8306S switches"
++ select SWCONFIG
++
+ config FIXED_PHY
+ bool "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
+ depends on PHYLIB=y
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -19,6 +19,7 @@ obj-$(CONFIG_MVSWITCH_PHY) += mvswitch.o
+ obj-$(CONFIG_IP17XX_PHY) += ip17xx.o
+ obj-$(CONFIG_REALTEK_PHY) += realtek.o
+ obj-$(CONFIG_AR8216_PHY) += ar8216.o
++obj-$(CONFIG_RTL8306_PHY) += rtl8306.o
+ obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
+ obj-$(CONFIG_FIXED_PHY) += fixed.o
+ obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o