aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-2.6.39/420-gpiodev.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2011-04-12 19:39:20 +0000
committerFelix Fietkau <nbd@openwrt.org>2011-04-12 19:39:20 +0000
commit127e4ebd32d51070fd5763e4d50aba211b02de6a (patch)
tree510a31b05cfa6ae4477fd738371cc12d3df27853 /target/linux/generic/patches-2.6.39/420-gpiodev.patch
parent512bb389ee6125135c6da818686f98774191b457 (diff)
downloadupstream-127e4ebd32d51070fd5763e4d50aba211b02de6a.tar.gz
upstream-127e4ebd32d51070fd5763e4d50aba211b02de6a.tar.bz2
upstream-127e4ebd32d51070fd5763e4d50aba211b02de6a.zip
generic: Add support for 2.6.39
Add support for 2.6.39 based on rc3. Runtime tested on bcm63xx. SVN-Revision: 26615
Diffstat (limited to 'target/linux/generic/patches-2.6.39/420-gpiodev.patch')
-rw-r--r--target/linux/generic/patches-2.6.39/420-gpiodev.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/target/linux/generic/patches-2.6.39/420-gpiodev.patch b/target/linux/generic/patches-2.6.39/420-gpiodev.patch
new file mode 100644
index 0000000000..f41d5a6850
--- /dev/null
+++ b/target/linux/generic/patches-2.6.39/420-gpiodev.patch
@@ -0,0 +1,27 @@
+--- a/drivers/char/Kconfig
++++ b/drivers/char/Kconfig
+@@ -511,6 +511,14 @@ config NSC_GPIO
+ pc8736x_gpio drivers. If those drivers are built as
+ modules, this one will be too, named nsc_gpio
+
++config GPIO_DEVICE
++ tristate "GPIO device support"
++ depends on GENERIC_GPIO
++ help
++ Say Y to enable Linux GPIO device support. This allows control of
++ GPIO pins using a character device
++
++
+ config RAW_DRIVER
+ tristate "RAW driver (/dev/raw/rawN)"
+ depends on BLOCK
+--- a/drivers/char/Makefile
++++ b/drivers/char/Makefile
+@@ -47,6 +47,7 @@ obj-$(CONFIG_NWFLASH) += nwflash.o
+ obj-$(CONFIG_SCx200_GPIO) += scx200_gpio.o
+ obj-$(CONFIG_PC8736x_GPIO) += pc8736x_gpio.o
+ obj-$(CONFIG_NSC_GPIO) += nsc_gpio.o
++obj-$(CONFIG_GPIO_DEVICE) += gpio_dev.o
+ obj-$(CONFIG_GPIO_TB0219) += tb0219.o
+ obj-$(CONFIG_TELCLOCK) += tlclk.o
+