aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-2.6.37/012-extra_optimization.patch
diff options
context:
space:
mode:
authorAlexandros C. Couloumbis <alex@ozo.com>2010-11-03 16:13:33 +0000
committerAlexandros C. Couloumbis <alex@ozo.com>2010-11-03 16:13:33 +0000
commita2d17ea8cf06f36d67c0d8850e580ce21a6bb837 (patch)
tree15c9d10a1c3c5b8cc071618dcf5210a9beaeff37 /target/linux/generic/patches-2.6.37/012-extra_optimization.patch
parent55081c6a197789823d03f6c16a47312407c611da (diff)
downloadupstream-a2d17ea8cf06f36d67c0d8850e580ce21a6bb837.tar.gz
upstream-a2d17ea8cf06f36d67c0d8850e580ce21a6bb837.tar.bz2
upstream-a2d17ea8cf06f36d67c0d8850e580ce21a6bb837.zip
target/linux: add preliminary 2.6.37 kernel support
SVN-Revision: 23828
Diffstat (limited to 'target/linux/generic/patches-2.6.37/012-extra_optimization.patch')
-rw-r--r--target/linux/generic/patches-2.6.37/012-extra_optimization.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/target/linux/generic/patches-2.6.37/012-extra_optimization.patch b/target/linux/generic/patches-2.6.37/012-extra_optimization.patch
new file mode 100644
index 0000000000..d7066486fc
--- /dev/null
+++ b/target/linux/generic/patches-2.6.37/012-extra_optimization.patch
@@ -0,0 +1,21 @@
+--- a/Makefile
++++ b/Makefile
+@@ -540,7 +540,7 @@ all: vmlinux
+ ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
+ KBUILD_CFLAGS += -Os
+ else
+-KBUILD_CFLAGS += -O2
++KBUILD_CFLAGS += -O2 -fno-reorder-blocks -fno-tree-ch
+ endif
+
+ include $(srctree)/arch/$(SRCARCH)/Makefile
+@@ -595,6 +595,9 @@ endif
+ NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
+ CHECKFLAGS += $(NOSTDINC_FLAGS)
+
++# improve gcc optimization
++CFLAGS += $(call cc-option,-funit-at-a-time,)
++
+ # warn about C99 declaration after statement
+ KBUILD_CFLAGS += $(call cc-option,-Wdeclaration-after-statement,)
+