aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-2.6.36
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2010-12-17 17:10:11 +0000
committerGabor Juhos <juhosg@openwrt.org>2010-12-17 17:10:11 +0000
commita059a11ee1e03c0cbe1dd400328b2d71820848d2 (patch)
tree7e1bddd9791112144a99223f58459db44c0a8c4f /target/linux/generic/patches-2.6.36
parent3b8a79395ae9042a0717ebbb05996c52d9f320f3 (diff)
downloadupstream-a059a11ee1e03c0cbe1dd400328b2d71820848d2.tar.gz
upstream-a059a11ee1e03c0cbe1dd400328b2d71820848d2.tar.bz2
upstream-a059a11ee1e03c0cbe1dd400328b2d71820848d2.zip
generic: add LED trigger for USB device presence/activity
SVN-Revision: 24646
Diffstat (limited to 'target/linux/generic/patches-2.6.36')
-rw-r--r--target/linux/generic/patches-2.6.36/403-ledtrig-usbdev.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/target/linux/generic/patches-2.6.36/403-ledtrig-usbdev.patch b/target/linux/generic/patches-2.6.36/403-ledtrig-usbdev.patch
new file mode 100644
index 0000000000..fe334d5ed1
--- /dev/null
+++ b/target/linux/generic/patches-2.6.36/403-ledtrig-usbdev.patch
@@ -0,0 +1,21 @@
+--- a/drivers/leds/Kconfig
++++ b/drivers/leds/Kconfig
+@@ -391,4 +391,11 @@ config LEDS_TRIGGER_NETDEV
+ This allows LEDs to be controlled by network device activity.
+ If unsure, say Y.
+
++config LEDS_TRIGGER_USBDEV
++ tristate "LED USB device Trigger"
++ depends on USB && LEDS_TRIGGERS
++ help
++ This allows LEDs to be controlled by the presence/activity of
++ an USB device. If unsure, say N.
++
+ endif # NEW_LEDS
+--- a/drivers/leds/Makefile
++++ b/drivers/leds/Makefile
+@@ -51,3 +51,4 @@ obj-$(CONFIG_LEDS_TRIGGER_GPIO) += ledt
+ obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
+ obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o
+ obj-$(CONFIG_LEDS_TRIGGER_NETDEV) += ledtrig-netdev.o
++obj-$(CONFIG_LEDS_TRIGGER_USBDEV) += ledtrig-usbdev.o