aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-2.6.36/970-ocf_kbuild_integration.patch
diff options
context:
space:
mode:
authorAlexandros C. Couloumbis <alex@ozo.com>2010-08-29 14:35:23 +0000
committerAlexandros C. Couloumbis <alex@ozo.com>2010-08-29 14:35:23 +0000
commit93d46eff0251eed425d040eb57ab884881cc7bbf (patch)
treef0db464d80e07fbb18c9f99ac73f45aadf7e22a6 /target/linux/generic/patches-2.6.36/970-ocf_kbuild_integration.patch
parent324a2cedd382a542391a01b2092686b0befbbf6a (diff)
downloadupstream-93d46eff0251eed425d040eb57ab884881cc7bbf.tar.gz
upstream-93d46eff0251eed425d040eb57ab884881cc7bbf.tar.bz2
upstream-93d46eff0251eed425d040eb57ab884881cc7bbf.zip
linux/generic: add kernel 2.6.36 preliminary support
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@22832 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic/patches-2.6.36/970-ocf_kbuild_integration.patch')
-rw-r--r--target/linux/generic/patches-2.6.36/970-ocf_kbuild_integration.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/generic/patches-2.6.36/970-ocf_kbuild_integration.patch b/target/linux/generic/patches-2.6.36/970-ocf_kbuild_integration.patch
new file mode 100644
index 0000000000..1e95858e46
--- /dev/null
+++ b/target/linux/generic/patches-2.6.36/970-ocf_kbuild_integration.patch
@@ -0,0 +1,20 @@
+--- a/crypto/Kconfig
++++ b/crypto/Kconfig
+@@ -844,3 +844,6 @@ config CRYPTO_ANSI_CPRNG
+ source "drivers/crypto/Kconfig"
+
+ endif # if CRYPTO
++
++source "crypto/ocf/Kconfig"
++
+--- a/crypto/Makefile
++++ b/crypto/Makefile
+@@ -86,6 +86,8 @@ obj-$(CONFIG_CRYPTO_ANSI_CPRNG) += ansi_
+ obj-$(CONFIG_CRYPTO_TEST) += tcrypt.o
+ obj-$(CONFIG_CRYPTO_GHASH) += ghash-generic.o
+
++obj-$(CONFIG_OCF_OCF) += ocf/
++
+ #
+ # generic algorithms and the async_tx api
+ #