aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-2.6.32/680-phy_ar8216.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2010-06-26 20:42:58 +0000
committerFelix Fietkau <nbd@openwrt.org>2010-06-26 20:42:58 +0000
commitda1bb88a2b900f0392b731ec47c5e1bff956fd8f (patch)
tree597146471e3eeafb4ba55e802e80b896770808ff /target/linux/generic/patches-2.6.32/680-phy_ar8216.patch
parent6117c04c9416b295347fb45c37e430f01df1d0d9 (diff)
downloadupstream-da1bb88a2b900f0392b731ec47c5e1bff956fd8f.tar.gz
upstream-da1bb88a2b900f0392b731ec47c5e1bff956fd8f.tar.bz2
upstream-da1bb88a2b900f0392b731ec47c5e1bff956fd8f.zip
rename target/linux/generic-2.6 to generic
SVN-Revision: 21952
Diffstat (limited to 'target/linux/generic/patches-2.6.32/680-phy_ar8216.patch')
-rw-r--r--target/linux/generic/patches-2.6.32/680-phy_ar8216.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/generic/patches-2.6.32/680-phy_ar8216.patch b/target/linux/generic/patches-2.6.32/680-phy_ar8216.patch
new file mode 100644
index 0000000000..0566600a0e
--- /dev/null
+++ b/target/linux/generic/patches-2.6.32/680-phy_ar8216.patch
@@ -0,0 +1,23 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -106,6 +106,10 @@ config IP17XX_PHY
+ tristate "Driver for IC+ IP17xx switches"
+ select SWCONFIG
+
++config AR8216_PHY
++ tristate "Driver for Atheros AR8216 switches"
++ select SWCONFIG
++
+ config FIXED_PHY
+ bool "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
+ depends on PHYLIB=y
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -18,6 +18,7 @@ obj-$(CONFIG_ADM6996_PHY) += adm6996.o
+ obj-$(CONFIG_MVSWITCH_PHY) += mvswitch.o
+ obj-$(CONFIG_IP17XX_PHY) += ip17xx.o
+ obj-$(CONFIG_REALTEK_PHY) += realtek.o
++obj-$(CONFIG_AR8216_PHY) += ar8216.o
+ obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
+ obj-$(CONFIG_FIXED_PHY) += fixed.o
+ obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o