aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/hack-5.10
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2023-07-01 14:31:42 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2023-07-01 14:31:42 +0200
commit0344144e771c71b764966551283814de3653ce6a (patch)
tree09913ef1fe7b83726e4eea5968c4af9d41dcdcc8 /target/linux/generic/hack-5.10
parent2034387af45f11c933e36ebdde4ca198c45068f9 (diff)
downloadupstream-0344144e771c71b764966551283814de3653ce6a.tar.gz
upstream-0344144e771c71b764966551283814de3653ce6a.tar.bz2
upstream-0344144e771c71b764966551283814de3653ce6a.zip
kernel: bump 5.10 to 5.10.185
Removed because upstreamed: uml/patches-5.10/001-um-Fix-build-w-o-CONFIG_PM_SLEEP.patch All other patches automatically rebased. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'target/linux/generic/hack-5.10')
-rw-r--r--target/linux/generic/hack-5.10/280-rfkill-stubs.patch2
-rw-r--r--target/linux/generic/hack-5.10/721-net-add-packet-mangeling.patch4
-rw-r--r--target/linux/generic/hack-5.10/780-usb-net-MeigLink_modem_support.patch2
3 files changed, 4 insertions, 4 deletions
diff --git a/target/linux/generic/hack-5.10/280-rfkill-stubs.patch b/target/linux/generic/hack-5.10/280-rfkill-stubs.patch
index 2e48aea1cf..8715a1a5c6 100644
--- a/target/linux/generic/hack-5.10/280-rfkill-stubs.patch
+++ b/target/linux/generic/hack-5.10/280-rfkill-stubs.patch
@@ -26,7 +26,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
* @name: name of the struct -- the string is not copied internally
--- a/net/Makefile
+++ b/net/Makefile
-@@ -53,7 +53,7 @@ obj-$(CONFIG_TIPC) += tipc/
+@@ -52,7 +52,7 @@ obj-$(CONFIG_TIPC) += tipc/
obj-$(CONFIG_NETLABEL) += netlabel/
obj-$(CONFIG_IUCV) += iucv/
obj-$(CONFIG_SMC) += smc/
diff --git a/target/linux/generic/hack-5.10/721-net-add-packet-mangeling.patch b/target/linux/generic/hack-5.10/721-net-add-packet-mangeling.patch
index 051246c3d6..e6e7bfc045 100644
--- a/target/linux/generic/hack-5.10/721-net-add-packet-mangeling.patch
+++ b/target/linux/generic/hack-5.10/721-net-add-packet-mangeling.patch
@@ -35,7 +35,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
/* Specifies the type of the struct net_device::ml_priv pointer */
enum netdev_ml_priv_type {
-@@ -2023,6 +2025,11 @@ struct net_device {
+@@ -2022,6 +2024,11 @@ struct net_device {
const struct tlsdev_ops *tlsdev_ops;
#endif
@@ -47,7 +47,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
const struct header_ops *header_ops;
unsigned int flags;
-@@ -2113,6 +2120,10 @@ struct net_device {
+@@ -2109,6 +2116,10 @@ struct net_device {
struct mpls_dev __rcu *mpls_ptr;
#endif
diff --git a/target/linux/generic/hack-5.10/780-usb-net-MeigLink_modem_support.patch b/target/linux/generic/hack-5.10/780-usb-net-MeigLink_modem_support.patch
index 21ddfc7a11..d92387ffe3 100644
--- a/target/linux/generic/hack-5.10/780-usb-net-MeigLink_modem_support.patch
+++ b/target/linux/generic/hack-5.10/780-usb-net-MeigLink_modem_support.patch
@@ -19,7 +19,7 @@
#define QUECTEL_VENDOR_ID 0x2c7c
/* These Quectel products use Quectel's vendor ID */
-@@ -1169,6 +1171,11 @@ static const struct usb_device_id option
+@@ -1173,6 +1175,11 @@ static const struct usb_device_id option
.driver_info = ZLP },
{ USB_DEVICE(QUECTEL_VENDOR_ID, QUECTEL_PRODUCT_BG96),
.driver_info = RSVD(4) },