aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/hack-4.14/220-gc_sections.patch
diff options
context:
space:
mode:
authorStijn Tintel <stijn@linux-ipv6.be>2018-01-02 22:12:28 +0100
committerStijn Tintel <stijn@linux-ipv6.be>2018-01-03 00:07:10 +0200
commitc5ca1c9ab65bfe1e6fc74230f8c0121230562b1c (patch)
tree1b36e4b2da9e188fae016bfe77e7d4140865a9bf /target/linux/generic/hack-4.14/220-gc_sections.patch
parent8b35da1552e844a47706aa3cde5115f0561a6492 (diff)
downloadupstream-c5ca1c9ab65bfe1e6fc74230f8c0121230562b1c.tar.gz
upstream-c5ca1c9ab65bfe1e6fc74230f8c0121230562b1c.tar.bz2
upstream-c5ca1c9ab65bfe1e6fc74230f8c0121230562b1c.zip
kernel: bump 4.14 to 4.14.11
Rename unwinder config symbols to match upstream changes. Refresh patches. Update patch that no longer applies: 202-reduce_module_size.patch Also enable CONFIG_PAGE_TABLE_ISOLATION. This feature was backported from 4.15 to the 4.14 stable series. It is enabled by default, so enable it in OpenWrt as well. Compile-tested on x86/64. Runtime-tested on x86/64. Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
Diffstat (limited to 'target/linux/generic/hack-4.14/220-gc_sections.patch')
-rw-r--r--target/linux/generic/hack-4.14/220-gc_sections.patch6
1 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/generic/hack-4.14/220-gc_sections.patch b/target/linux/generic/hack-4.14/220-gc_sections.patch
index 4463e2313e..e06ddb80d4 100644
--- a/target/linux/generic/hack-4.14/220-gc_sections.patch
+++ b/target/linux/generic/hack-4.14/220-gc_sections.patch
@@ -21,9 +21,9 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
--- a/Makefile
+++ b/Makefile
-@@ -410,6 +410,11 @@ KBUILD_AFLAGS_MODULE := -DMODULE
- KBUILD_CFLAGS_MODULE := -DMODULE
+@@ -405,6 +405,11 @@ KBUILD_CFLAGS_MODULE := -DMODULE
KBUILD_LDFLAGS_MODULE = -T $(srctree)/scripts/module-common.lds $(if $(CONFIG_PROFILING),,-s)
+ GCC_PLUGINS_CFLAGS :=
+ifdef CONFIG_LD_DEAD_CODE_DATA_ELIMINATION
+KBUILD_CFLAGS_KERNEL += $(call cc-option,-ffunction-sections,)
@@ -33,7 +33,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
# Read KERNELRELEASE from include/config/kernel.release (if it exists)
KERNELRELEASE = $(shell cat include/config/kernel.release 2> /dev/null)
KERNELVERSION = $(VERSION)$(if $(PATCHLEVEL),.$(PATCHLEVEL)$(if $(SUBLEVEL),.$(SUBLEVEL)))$(EXTRAVERSION)
-@@ -783,11 +788,6 @@ ifdef CONFIG_DEBUG_SECTION_MISMATCH
+@@ -784,11 +789,6 @@ ifdef CONFIG_DEBUG_SECTION_MISMATCH
KBUILD_CFLAGS += $(call cc-option, -fno-inline-functions-called-once)
endif