aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/files/drivers/mtd/mtdsplit/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-01-17 10:40:51 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-01-17 10:40:51 +0000
commitbdd2772f1d1f822acedb7dadf9d5978ce2dbc2e2 (patch)
treeb8b786e2eff7311ec4bb2b31b88edcab2dd8c0c5 /target/linux/generic/files/drivers/mtd/mtdsplit/Makefile
parent3348279ecae916154c87b18d3653f6f7b7dbe476 (diff)
downloadupstream-bdd2772f1d1f822acedb7dadf9d5978ce2dbc2e2.tar.gz
upstream-bdd2772f1d1f822acedb7dadf9d5978ce2dbc2e2.tar.bz2
upstream-bdd2772f1d1f822acedb7dadf9d5978ce2dbc2e2.zip
kernel: mtdsplit: add support for brnImages
This adds brnImage (used with the brnboot bootloader) firmware parsing support. brnboot verifies the integrity of the firmware stored on the "Code Image" partitions by looking at the 12 byte footer at the very end of the partition. This footer contains the checksum of the original brnImage (kernel + rootfs/squashfs) and must not be touched (by our JFFS2 rootfs_data - otherwise the image will not be bootable anymore). Big thanks to Mathias Kresin for analyzing the brnImage structure and finding out the information how to keep images valid even when adding a nested rootfs_data partition. Signed-off-by: Martin Blumenstingl <martin.blumenstingl@googlemail.com> SVN-Revision: 48261
Diffstat (limited to 'target/linux/generic/files/drivers/mtd/mtdsplit/Makefile')
-rw-r--r--target/linux/generic/files/drivers/mtd/mtdsplit/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/target/linux/generic/files/drivers/mtd/mtdsplit/Makefile b/target/linux/generic/files/drivers/mtd/mtdsplit/Makefile
index e09476bc20..ca24c717dc 100644
--- a/target/linux/generic/files/drivers/mtd/mtdsplit/Makefile
+++ b/target/linux/generic/files/drivers/mtd/mtdsplit/Makefile
@@ -6,3 +6,4 @@ obj-$(CONFIG_MTD_SPLIT_FIT_FW) += mtdsplit_fit.o
obj-$(CONFIG_MTD_SPLIT_LZMA_FW) += mtdsplit_lzma.o
obj-$(CONFIG_MTD_SPLIT_TPLINK_FW) += mtdsplit_tplink.o
obj-$(CONFIG_MTD_SPLIT_TRX_FW) += mtdsplit_trx.o
+obj-$(CONFIG_MTD_SPLIT_BRNIMAGE_FW) += mtdsplit_brnimage.o