aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/backport-4.9
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2018-07-22 17:05:09 +0200
committerFelix Fietkau <nbd@nbd.name>2018-07-22 17:16:35 +0200
commit7ad20678e5fbbd5dbce4663ed0d8f9bdb1ab30ab (patch)
tree358e8f6c52ef8c274d57b2de491184602e3459be /target/linux/generic/backport-4.9
parentc527d0ec189bc3493c15dee15fcfd635b8fa54ff (diff)
downloadupstream-7ad20678e5fbbd5dbce4663ed0d8f9bdb1ab30ab.tar.gz
upstream-7ad20678e5fbbd5dbce4663ed0d8f9bdb1ab30ab.tar.bz2
upstream-7ad20678e5fbbd5dbce4663ed0d8f9bdb1ab30ab.zip
kernel: backport a change to 4.9 which disables overly aggressive warnings on gcc 8
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'target/linux/generic/backport-4.9')
-rw-r--r--target/linux/generic/backport-4.9/014-Kbuild-suppress-packed-not-aligned-warning-for-defau.patch45
1 files changed, 45 insertions, 0 deletions
diff --git a/target/linux/generic/backport-4.9/014-Kbuild-suppress-packed-not-aligned-warning-for-defau.patch b/target/linux/generic/backport-4.9/014-Kbuild-suppress-packed-not-aligned-warning-for-defau.patch
new file mode 100644
index 0000000000..a6e312a092
--- /dev/null
+++ b/target/linux/generic/backport-4.9/014-Kbuild-suppress-packed-not-aligned-warning-for-defau.patch
@@ -0,0 +1,45 @@
+From: Xiongfeng Wang <xiongfeng.wang@linaro.org>
+Date: Thu, 11 Jan 2018 17:22:29 +0800
+Subject: [PATCH] Kbuild: suppress packed-not-aligned warning for default
+ setting only
+
+gcc-8 reports many -Wpacked-not-aligned warnings. The below are some
+examples.
+
+./include/linux/ceph/msgr.h:67:1: warning: alignment 1 of 'struct
+ceph_entity_addr' is less than 8 [-Wpacked-not-aligned]
+ } __attribute__ ((packed));
+
+./include/linux/ceph/msgr.h:67:1: warning: alignment 1 of 'struct
+ceph_entity_addr' is less than 8 [-Wpacked-not-aligned]
+ } __attribute__ ((packed));
+
+./include/linux/ceph/msgr.h:67:1: warning: alignment 1 of 'struct
+ceph_entity_addr' is less than 8 [-Wpacked-not-aligned]
+ } __attribute__ ((packed));
+
+This patch suppresses this kind of warnings for default setting.
+
+Signed-off-by: Xiongfeng Wang <xiongfeng.wang@linaro.org>
+Signed-off-by: Masahiro Yamada <yamada.masahiro@socionext.com>
+---
+
+--- a/scripts/Makefile.extrawarn
++++ b/scripts/Makefile.extrawarn
+@@ -10,6 +10,8 @@
+ # are not supported by all versions of the compiler
+ # ==========================================================================
+
++KBUILD_CFLAGS += $(call cc-disable-warning, packed-not-aligned)
++
+ ifeq ("$(origin W)", "command line")
+ export KBUILD_ENABLE_EXTRA_GCC_CHECKS := $(W)
+ endif
+@@ -25,6 +27,7 @@ warning-1 += -Wold-style-definition
+ warning-1 += $(call cc-option, -Wmissing-include-dirs)
+ warning-1 += $(call cc-option, -Wunused-but-set-variable)
+ warning-1 += $(call cc-option, -Wunused-const-variable)
++warning-1 += $(call cc-option, -Wpacked-not-aligned)
+ warning-1 += $(call cc-disable-warning, missing-field-initializers)
+ warning-1 += $(call cc-disable-warning, sign-compare)
+