aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.34/650-swconfig.patch
diff options
context:
space:
mode:
authorAlexandros C. Couloumbis <alex@ozo.com>2010-03-11 12:24:17 +0000
committerAlexandros C. Couloumbis <alex@ozo.com>2010-03-11 12:24:17 +0000
commitd138f99bb2325af7821b5ea592bf7e5602ef228e (patch)
tree7f77c9b45c329c20826f8a1f1a2875132a56b307 /target/linux/generic-2.6/patches-2.6.34/650-swconfig.patch
parentf086ba1d82562fd9f373a737b62353dfccaa7c75 (diff)
downloadupstream-d138f99bb2325af7821b5ea592bf7e5602ef228e.tar.gz
upstream-d138f99bb2325af7821b5ea592bf7e5602ef228e.tar.bz2
upstream-d138f99bb2325af7821b5ea592bf7e5602ef228e.zip
generic-2.6: add 2.6.34 preliminary support (patches)
SVN-Revision: 20140
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.34/650-swconfig.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.34/650-swconfig.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.34/650-swconfig.patch b/target/linux/generic-2.6/patches-2.6.34/650-swconfig.patch
new file mode 100644
index 0000000000..6825037ce9
--- /dev/null
+++ b/target/linux/generic-2.6/patches-2.6.34/650-swconfig.patch
@@ -0,0 +1,25 @@
+--- a/drivers/net/phy/Kconfig
++++ b/drivers/net/phy/Kconfig
+@@ -13,6 +13,12 @@ menuconfig PHYLIB
+
+ if PHYLIB
+
++config SWCONFIG
++ tristate "Switch configuration API"
++ ---help---
++ Switch configuration API using netlink. This allows
++ you to configure the VLAN features of certain switches.
++
+ comment "MII PHY device drivers"
+
+ config MARVELL_PHY
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
+@@ -3,6 +3,7 @@
+ libphy-objs := phy.o phy_device.o mdio_bus.o
+
+ obj-$(CONFIG_PHYLIB) += libphy.o
++obj-$(CONFIG_SWCONFIG) += swconfig.o
+ obj-$(CONFIG_MARVELL_PHY) += marvell.o
+ obj-$(CONFIG_DAVICOM_PHY) += davicom.o
+ obj-$(CONFIG_CICADA_PHY) += cicada.o