aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.34/420-gpiodev.patch
diff options
context:
space:
mode:
authorAlexandros C. Couloumbis <alex@ozo.com>2010-03-11 12:24:17 +0000
committerAlexandros C. Couloumbis <alex@ozo.com>2010-03-11 12:24:17 +0000
commitd138f99bb2325af7821b5ea592bf7e5602ef228e (patch)
tree7f77c9b45c329c20826f8a1f1a2875132a56b307 /target/linux/generic-2.6/patches-2.6.34/420-gpiodev.patch
parentf086ba1d82562fd9f373a737b62353dfccaa7c75 (diff)
downloadupstream-d138f99bb2325af7821b5ea592bf7e5602ef228e.tar.gz
upstream-d138f99bb2325af7821b5ea592bf7e5602ef228e.tar.bz2
upstream-d138f99bb2325af7821b5ea592bf7e5602ef228e.zip
generic-2.6: add 2.6.34 preliminary support (patches)
SVN-Revision: 20140
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.34/420-gpiodev.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.34/420-gpiodev.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.34/420-gpiodev.patch b/target/linux/generic-2.6/patches-2.6.34/420-gpiodev.patch
new file mode 100644
index 0000000000..ebc430f3ec
--- /dev/null
+++ b/target/linux/generic-2.6/patches-2.6.34/420-gpiodev.patch
@@ -0,0 +1,27 @@
+--- a/drivers/char/Kconfig
++++ b/drivers/char/Kconfig
+@@ -1016,6 +1016,14 @@ config CS5535_GPIO
+
+ If compiled as a module, it will be called cs5535_gpio.
+
++config GPIO_DEVICE
++ tristate "GPIO device support"
++ depends on GENERIC_GPIO
++ help
++ Say Y to enable Linux GPIO device support. This allows control of
++ GPIO pins using a character device
++
++
+ config RAW_DRIVER
+ tristate "RAW driver (/dev/raw/rawN)"
+ depends on BLOCK
+--- a/drivers/char/Makefile
++++ b/drivers/char/Makefile
+@@ -95,6 +95,7 @@ obj-$(CONFIG_SCx200_GPIO) += scx200_gpio
+ obj-$(CONFIG_PC8736x_GPIO) += pc8736x_gpio.o
+ obj-$(CONFIG_NSC_GPIO) += nsc_gpio.o
+ obj-$(CONFIG_CS5535_GPIO) += cs5535_gpio.o
++obj-$(CONFIG_GPIO_DEVICE) += gpio_dev.o
+ obj-$(CONFIG_GPIO_TB0219) += tb0219.o
+ obj-$(CONFIG_TELCLOCK) += tlclk.o
+