aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.34/400-ledtrig_morse.patch
diff options
context:
space:
mode:
authorAlexandros C. Couloumbis <alex@ozo.com>2010-03-11 12:24:17 +0000
committerAlexandros C. Couloumbis <alex@ozo.com>2010-03-11 12:24:17 +0000
commitd138f99bb2325af7821b5ea592bf7e5602ef228e (patch)
tree7f77c9b45c329c20826f8a1f1a2875132a56b307 /target/linux/generic-2.6/patches-2.6.34/400-ledtrig_morse.patch
parentf086ba1d82562fd9f373a737b62353dfccaa7c75 (diff)
downloadupstream-d138f99bb2325af7821b5ea592bf7e5602ef228e.tar.gz
upstream-d138f99bb2325af7821b5ea592bf7e5602ef228e.tar.bz2
upstream-d138f99bb2325af7821b5ea592bf7e5602ef228e.zip
generic-2.6: add 2.6.34 preliminary support (patches)
SVN-Revision: 20140
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.34/400-ledtrig_morse.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.34/400-ledtrig_morse.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.34/400-ledtrig_morse.patch b/target/linux/generic-2.6/patches-2.6.34/400-ledtrig_morse.patch
new file mode 100644
index 0000000000..855b3dee53
--- /dev/null
+++ b/target/linux/generic-2.6/patches-2.6.34/400-ledtrig_morse.patch
@@ -0,0 +1,18 @@
+--- a/drivers/leds/Kconfig
++++ b/drivers/leds/Kconfig
+@@ -337,4 +337,8 @@ config LEDS_TRIGGER_DEFAULT_ON
+ comment "iptables trigger is under Netfilter config (LED target)"
+ depends on LEDS_TRIGGERS
+
++config LEDS_TRIGGER_MORSE
++ tristate "LED Morse Trigger"
++ depends on LEDS_TRIGGERS
++
+ endif # NEW_LEDS
+--- a/drivers/leds/Makefile
++++ b/drivers/leds/Makefile
+@@ -44,3 +44,4 @@ obj-$(CONFIG_LEDS_TRIGGER_HEARTBEAT) +=
+ obj-$(CONFIG_LEDS_TRIGGER_BACKLIGHT) += ledtrig-backlight.o
+ obj-$(CONFIG_LEDS_TRIGGER_GPIO) += ledtrig-gpio.o
+ obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
++obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o