aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.33/970-ocf_kbuild_integration.patch
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-05-04 20:59:19 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-05-04 20:59:19 +0000
commit32e7340bf26d1d59aefb14bf1af4c2e3cb9a9642 (patch)
treee04b357c36a5042b6f844d01e89633949600fdb3 /target/linux/generic-2.6/patches-2.6.33/970-ocf_kbuild_integration.patch
parentd30f29165acba8532b117bd7c61f71be4cd6619c (diff)
downloadupstream-32e7340bf26d1d59aefb14bf1af4c2e3cb9a9642.tar.gz
upstream-32e7340bf26d1d59aefb14bf1af4c2e3cb9a9642.tar.bz2
upstream-32e7340bf26d1d59aefb14bf1af4c2e3cb9a9642.zip
update OCF framework to version 20100325
SVN-Revision: 21356
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.33/970-ocf_kbuild_integration.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.33/970-ocf_kbuild_integration.patch19
1 files changed, 7 insertions, 12 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.33/970-ocf_kbuild_integration.patch b/target/linux/generic-2.6/patches-2.6.33/970-ocf_kbuild_integration.patch
index 0c40bdc926..fd304613f7 100644
--- a/target/linux/generic-2.6/patches-2.6.33/970-ocf_kbuild_integration.patch
+++ b/target/linux/generic-2.6/patches-2.6.33/970-ocf_kbuild_integration.patch
@@ -1,25 +1,20 @@
--- a/crypto/Kconfig
+++ b/crypto/Kconfig
-@@ -823,6 +823,8 @@ config CRYPTO_ANSI_CPRNG
- ANSI X9.31 A.2.4. Not this option must be enabled if CRYPTO_FIPS
- is selected
-
-+source "crypto/ocf/Kconfig"
-+
+@@ -826,3 +826,6 @@ config CRYPTO_ANSI_CPRNG
source "drivers/crypto/Kconfig"
endif # if CRYPTO
++
++source "crypto/ocf/Kconfig"
++
--- a/crypto/Makefile
+++ b/crypto/Makefile
-@@ -86,6 +86,11 @@ obj-$(CONFIG_CRYPTO_TEST) += tcrypt.o
+@@ -85,6 +85,8 @@ obj-$(CONFIG_CRYPTO_ANSI_CPRNG) += ansi_
+ obj-$(CONFIG_CRYPTO_TEST) += tcrypt.o
obj-$(CONFIG_CRYPTO_GHASH) += ghash-generic.o
- #
-+# OCF
-+#
+obj-$(CONFIG_OCF_OCF) += ocf/
+
-+#
+ #
# generic algorithms and the async_tx api
#
- obj-$(CONFIG_XOR_BLOCKS) += xor.o