aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.31
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2010-01-01 11:11:17 +0000
committerGabor Juhos <juhosg@openwrt.org>2010-01-01 11:11:17 +0000
commit311c91775d97f0932231aa114e39a14cfeffef51 (patch)
tree3a3647cf07d4dd0eb60b031c06b8c83fb8687d01 /target/linux/generic-2.6/patches-2.6.31
parentf759c749de09b04d2827cce5e54c88a9a7e9a6d7 (diff)
downloadupstream-311c91775d97f0932231aa114e39a14cfeffef51.tar.gz
upstream-311c91775d97f0932231aa114e39a14cfeffef51.tar.bz2
upstream-311c91775d97f0932231aa114e39a14cfeffef51.zip
kernel: update to 2.6.31.9 and 2.6.32.2, and refresh patches
SVN-Revision: 18982
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.31')
-rw-r--r--target/linux/generic-2.6/patches-2.6.31/020-mips_multi_machine_support.patch6
-rw-r--r--target/linux/generic-2.6/patches-2.6.31/150-netfilter_imq.patch8
2 files changed, 7 insertions, 7 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.31/020-mips_multi_machine_support.patch b/target/linux/generic-2.6/patches-2.6.31/020-mips_multi_machine_support.patch
index f602174c62..9c41c3c161 100644
--- a/target/linux/generic-2.6/patches-2.6.31/020-mips_multi_machine_support.patch
+++ b/target/linux/generic-2.6/patches-2.6.31/020-mips_multi_machine_support.patch
@@ -127,7 +127,7 @@
+}
--- a/arch/mips/kernel/Makefile
+++ b/arch/mips/kernel/Makefile
-@@ -87,6 +87,7 @@
+@@ -87,6 +87,7 @@ obj-$(CONFIG_GPIO_TXX9) += gpio_txx9.o
obj-$(CONFIG_KEXEC) += machine_kexec.o relocate_kernel.o
obj-$(CONFIG_EARLY_PRINTK) += early_printk.o
@@ -137,7 +137,7 @@
--- a/arch/mips/Kconfig
+++ b/arch/mips/Kconfig
-@@ -837,6 +837,9 @@
+@@ -837,6 +837,9 @@ config MIPS_DISABLE_OBSOLETE_IDE
config SYNC_R4K
bool
@@ -157,7 +157,7 @@
unsigned int vced_count, vcei_count;
-@@ -31,8 +32,12 @@
+@@ -31,8 +32,12 @@ static int show_cpuinfo(struct seq_file
/*
* For the first processor also print the system type
*/
diff --git a/target/linux/generic-2.6/patches-2.6.31/150-netfilter_imq.patch b/target/linux/generic-2.6/patches-2.6.31/150-netfilter_imq.patch
index cc9f5f263e..026e9bdee9 100644
--- a/target/linux/generic-2.6/patches-2.6.31/150-netfilter_imq.patch
+++ b/target/linux/generic-2.6/patches-2.6.31/150-netfilter_imq.patch
@@ -834,7 +834,7 @@
#include <linux/proc_fs.h>
#include <linux/seq_file.h>
#include <linux/stat.h>
-@@ -1686,7 +1689,11 @@ int dev_hard_start_xmit(struct sk_buff *
+@@ -1687,7 +1690,11 @@ int dev_hard_start_xmit(struct sk_buff *
int rc;
if (likely(!skb->next)) {
@@ -847,7 +847,7 @@
dev_queue_xmit_nit(skb, dev);
if (netif_needs_gso(dev, skb)) {
-@@ -1771,8 +1778,7 @@ u16 skb_tx_hash(const struct net_device
+@@ -1772,8 +1779,7 @@ u16 skb_tx_hash(const struct net_device
}
EXPORT_SYMBOL(skb_tx_hash);
@@ -857,7 +857,7 @@
{
const struct net_device_ops *ops = dev->netdev_ops;
u16 queue_index = 0;
-@@ -1785,6 +1791,7 @@ static struct netdev_queue *dev_pick_tx(
+@@ -1786,6 +1792,7 @@ static struct netdev_queue *dev_pick_tx(
skb_set_queue_mapping(skb, queue_index);
return netdev_get_tx_queue(dev, queue_index);
}
@@ -1033,7 +1033,7 @@
new->csum = old->csum;
new->local_df = old->local_df;
new->pkt_type = old->pkt_type;
-@@ -2778,6 +2867,13 @@ void __init skb_init(void)
+@@ -2779,6 +2868,13 @@ void __init skb_init(void)
0,
SLAB_HWCACHE_ALIGN|SLAB_PANIC,
NULL);