aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.25/002-lzma_decompress.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2008-05-18 20:26:43 +0000
committerGabor Juhos <juhosg@openwrt.org>2008-05-18 20:26:43 +0000
commit4503efda2da6e5868bbbd274c042622dc03edd8e (patch)
tree3678d3fa5a554dcf4f4295ab9dcb5ab026240683 /target/linux/generic-2.6/patches-2.6.25/002-lzma_decompress.patch
parente582f614b6e15517a9207b0a96a72b68f7a254df (diff)
downloadupstream-4503efda2da6e5868bbbd274c042622dc03edd8e.tar.gz
upstream-4503efda2da6e5868bbbd274c042622dc03edd8e.tar.bz2
upstream-4503efda2da6e5868bbbd274c042622dc03edd8e.zip
refresh generic 2.6.25 patches
SVN-Revision: 11189
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.25/002-lzma_decompress.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.25/002-lzma_decompress.patch14
1 files changed, 7 insertions, 7 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.25/002-lzma_decompress.patch b/target/linux/generic-2.6/patches-2.6.25/002-lzma_decompress.patch
index f2c31e75eb..73cf22a9b4 100644
--- a/target/linux/generic-2.6/patches-2.6.25/002-lzma_decompress.patch
+++ b/target/linux/generic-2.6/patches-2.6.25/002-lzma_decompress.patch
@@ -1,7 +1,7 @@
-Index: linux-2.6.25.1/include/linux/LzmaDecode.h
+Index: linux-2.6.25.4/include/linux/LzmaDecode.h
===================================================================
--- /dev/null
-+++ linux-2.6.25.1/include/linux/LzmaDecode.h
++++ linux-2.6.25.4/include/linux/LzmaDecode.h
@@ -0,0 +1,100 @@
+/*
+ LzmaDecode.h
@@ -103,10 +103,10 @@ Index: linux-2.6.25.1/include/linux/LzmaDecode.h
+ UInt32 *outSizeProcessed);
+
+#endif
-Index: linux-2.6.25.1/lib/LzmaDecode.c
+Index: linux-2.6.25.4/lib/LzmaDecode.c
===================================================================
--- /dev/null
-+++ linux-2.6.25.1/lib/LzmaDecode.c
++++ linux-2.6.25.4/lib/LzmaDecode.c
@@ -0,0 +1,663 @@
+/*
+ LzmaDecode.c
@@ -771,10 +771,10 @@ Index: linux-2.6.25.1/lib/LzmaDecode.c
+ *outSizeProcessed = nowPos;
+ return LZMA_RESULT_OK;
+}
-Index: linux-2.6.25.1/lib/Makefile
+Index: linux-2.6.25.4/lib/Makefile
===================================================================
---- linux-2.6.25.1.orig/lib/Makefile
-+++ linux-2.6.25.1/lib/Makefile
+--- linux-2.6.25.4.orig/lib/Makefile
++++ linux-2.6.25.4/lib/Makefile
@@ -14,7 +14,7 @@ lib-$(CONFIG_SMP) += cpumask.o
lib-y += kobject.o kref.o klist.o