aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.23/921-gpio_spi_driver.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2009-06-01 18:16:10 +0000
committerImre Kaloz <kaloz@openwrt.org>2009-06-01 18:16:10 +0000
commit671a899cc41ebadd8c88a8fc130e52578e2eb2fe (patch)
tree7b38bdc75edd61a80a8dd1846005185534667ae9 /target/linux/generic-2.6/patches-2.6.23/921-gpio_spi_driver.patch
parent87a6e2bb180aad33411f9d13392376891f73b4b1 (diff)
downloadupstream-671a899cc41ebadd8c88a8fc130e52578e2eb2fe.tar.gz
upstream-671a899cc41ebadd8c88a8fc130e52578e2eb2fe.tar.bz2
upstream-671a899cc41ebadd8c88a8fc130e52578e2eb2fe.zip
remove 2.6.23 support, as the last target using that has been nuked, too
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@16275 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.23/921-gpio_spi_driver.patch')
-rw-r--r--target/linux/generic-2.6/patches-2.6.23/921-gpio_spi_driver.patch24
1 files changed, 0 insertions, 24 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.23/921-gpio_spi_driver.patch b/target/linux/generic-2.6/patches-2.6.23/921-gpio_spi_driver.patch
deleted file mode 100644
index 1ad193249e..0000000000
--- a/target/linux/generic-2.6/patches-2.6.23/921-gpio_spi_driver.patch
+++ /dev/null
@@ -1,24 +0,0 @@
---- a/drivers/spi/Kconfig
-+++ b/drivers/spi/Kconfig
-@@ -100,6 +100,11 @@ config SPI_BUTTERFLY
- inexpensive battery powered microcontroller evaluation board.
- This same cable can be used to flash new firmware.
-
-+config SPI_GPIO
-+ tristate "GPIO API based bitbanging SPI controller"
-+ depends on SPI_MASTER && GENERIC_GPIO && EXPERIMENTAL
-+ select SPI_BITBANG
-+
- config SPI_IMX
- tristate "Freescale iMX SPI controller"
- depends on SPI_MASTER && ARCH_IMX && EXPERIMENTAL
---- a/drivers/spi/Makefile
-+++ b/drivers/spi/Makefile
-@@ -16,6 +16,7 @@ obj-$(CONFIG_SPI_BFIN) += spi_bfin5xx.
- obj-$(CONFIG_SPI_BITBANG) += spi_bitbang.o
- obj-$(CONFIG_SPI_AU1550) += au1550_spi.o
- obj-$(CONFIG_SPI_BUTTERFLY) += spi_butterfly.o
-+obj-$(CONFIG_SPI_GPIO) += spi_gpio.o
- obj-$(CONFIG_SPI_IMX) += spi_imx.o
- obj-$(CONFIG_SPI_LM70_LLP) += spi_lm70llp.o
- obj-$(CONFIG_SPI_PXA2XX) += pxa2xx_spi.o