aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/patches-2.6.22
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2007-09-28 20:06:52 +0000
committerGabor Juhos <juhosg@openwrt.org>2007-09-28 20:06:52 +0000
commit962738bdac443a84a019a0dd1b9dfaa551337f23 (patch)
tree3716d622a362211fd201c547b9e5ce09986c3f32 /target/linux/generic-2.6/patches-2.6.22
parente56807cce48b87ed56fd88c5cf68ce79e80dc485 (diff)
downloadupstream-962738bdac443a84a019a0dd1b9dfaa551337f23.tar.gz
upstream-962738bdac443a84a019a0dd1b9dfaa551337f23.tar.bz2
upstream-962738bdac443a84a019a0dd1b9dfaa551337f23.zip
make morse LED trigger available for all platforms
SVN-Revision: 9055
Diffstat (limited to 'target/linux/generic-2.6/patches-2.6.22')
-rw-r--r--target/linux/generic-2.6/patches-2.6.22/400-ledtrig_morse.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/target/linux/generic-2.6/patches-2.6.22/400-ledtrig_morse.patch b/target/linux/generic-2.6/patches-2.6.22/400-ledtrig_morse.patch
new file mode 100644
index 0000000000..f1602ed1cc
--- /dev/null
+++ b/target/linux/generic-2.6/patches-2.6.22/400-ledtrig_morse.patch
@@ -0,0 +1,19 @@
+--- linux-2.6.21.1.orig/drivers/leds/Kconfig 2007-09-09 07:15:28.000000000 +0200
++++ linux-2.6.21.1/drivers/leds/Kconfig 2007-09-13 19:36:35.000000000 +0200
+@@ -149,5 +149,9 @@
+ load average.
+ If unsure, say Y.
+
++config LEDS_TRIGGER_MORSE
++ tristate "LED Morse Trigger"
++ depends on LEDS_TRIGGERS
++
+ endmenu
+
+--- linux-2.6.21.1.orig/drivers/leds/Makefile 2007-09-09 07:15:28.000000000 +0200
++++ linux-2.6.21.1/drivers/leds/Makefile 2007-09-13 19:33:15.000000000 +0200
+@@ -23,3 +23,4 @@
+ obj-$(CONFIG_LEDS_TRIGGER_TIMER) += ledtrig-timer.o
+ obj-$(CONFIG_LEDS_TRIGGER_IDE_DISK) += ledtrig-ide-disk.o
+ obj-$(CONFIG_LEDS_TRIGGER_HEARTBEAT) += ledtrig-heartbeat.o
++obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o