aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.6/image/lzma-loader/Makefile
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2008-03-26 13:33:22 +0000
committerFlorian Fainelli <florian@openwrt.org>2008-03-26 13:33:22 +0000
commit6e8a4f219add9ffbc6bb5a9bc7fafcd301866f27 (patch)
tree23c281ee776a9563e330d7ab06ed0663b63c379c /target/linux/generic-2.6/image/lzma-loader/Makefile
parentb96aec3f500279b9eeb7e08e35a64774810a4aea (diff)
downloadupstream-6e8a4f219add9ffbc6bb5a9bc7fafcd301866f27.tar.gz
upstream-6e8a4f219add9ffbc6bb5a9bc7fafcd301866f27.tar.bz2
upstream-6e8a4f219add9ffbc6bb5a9bc7fafcd301866f27.zip
Generate a binary lzma-loader
SVN-Revision: 10661
Diffstat (limited to 'target/linux/generic-2.6/image/lzma-loader/Makefile')
-rw-r--r--target/linux/generic-2.6/image/lzma-loader/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/target/linux/generic-2.6/image/lzma-loader/Makefile b/target/linux/generic-2.6/image/lzma-loader/Makefile
index e3a98afbce..171c3c3938 100644
--- a/target/linux/generic-2.6/image/lzma-loader/Makefile
+++ b/target/linux/generic-2.6/image/lzma-loader/Makefile
@@ -33,11 +33,15 @@ $(PKG_BUILD_DIR)/vmlinux.lzma: $(KDIR)/vmlinux.lzma
$(KDIR)/loader$(LOADER_TYPE).elf: $(PKG_BUILD_DIR)/lzma.elf
$(CP) $< $@
+$(KDIR)/loader$(LOADER_TYPE).bin: $(PKG_BUILD_DIR)/lzma.bin
+ $(CP) $< $@
+
download:
prepare: $(PKG_BUILD_DIR)/.prepared
-compile: $(KDIR)/loader$(LOADER_TYPE).elf
+compile: $(KDIR)/loader$(LOADER_TYPE).elf $(KDIR)/loader$(LOADER_TYPE).bin
install:
clean:
rm -rf $(PKG_BUILD_DIR)
rm -f $(KDIR)/loader.elf
+ rm -f $(KDIR)/loader.bin