aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.4/patches/616-netfilter_imq.patch
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2009-05-28 15:55:54 +0000
committerFlorian Fainelli <florian@openwrt.org>2009-05-28 15:55:54 +0000
commitcec852c0870d3df36ed9e5bc03b6ff70f4d67c75 (patch)
tree0d7958494894e9ffae1853f3ee7fe3ce0f788b61 /target/linux/generic-2.4/patches/616-netfilter_imq.patch
parentb7ae5e7b7cb2cb23effc6007b5bc8527be22e054 (diff)
downloadupstream-cec852c0870d3df36ed9e5bc03b6ff70f4d67c75.tar.gz
upstream-cec852c0870d3df36ed9e5bc03b6ff70f4d67c75.tar.bz2
upstream-cec852c0870d3df36ed9e5bc03b6ff70f4d67c75.zip
update to 2.4.37, tested on wrt54gs (#4766)
SVN-Revision: 16144
Diffstat (limited to 'target/linux/generic-2.4/patches/616-netfilter_imq.patch')
-rw-r--r--target/linux/generic-2.4/patches/616-netfilter_imq.patch6
1 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/generic-2.4/patches/616-netfilter_imq.patch b/target/linux/generic-2.4/patches/616-netfilter_imq.patch
index b8c0523df1..45f4d9d24c 100644
--- a/target/linux/generic-2.4/patches/616-netfilter_imq.patch
+++ b/target/linux/generic-2.4/patches/616-netfilter_imq.patch
@@ -23,7 +23,7 @@
MARK target support
CONFIG_IP_NF_TARGET_MARK
This option adds a `MARK' target, which allows you to create rules
-@@ -9919,6 +9935,20 @@ CONFIG_BONDING
+@@ -9931,6 +9947,20 @@ CONFIG_BONDING
say M here and read <file:Documentation/modules.txt>. The module
will be called bonding.o.
@@ -510,12 +510,12 @@
dep_tristate ' MARK target support' CONFIG_IP_NF_TARGET_MARK $CONFIG_IP_NF_MANGLE
+ dep_tristate ' IMQ target support' CONFIG_IP_NF_TARGET_IMQ $CONFIG_IP_NF_MANGLE
+ dep_tristate ' CLASSIFY target support (EXPERIMENTAL)' CONFIG_IP_NF_TARGET_CLASSIFY $CONFIG_IP_NF_MANGLE
fi
if [ "$CONFIG_IP_NF_CONNTRACK_MARK" != "n" ]; then
- dep_tristate ' CONNMARK target support' CONFIG_IP_NF_TARGET_CONNMARK $CONFIG_IP_NF_IPTABLES
--- a/net/ipv4/netfilter/Makefile
+++ b/net/ipv4/netfilter/Makefile
-@@ -138,6 +138,7 @@ obj-$(CONFIG_IP_NF_TARGET_TOS) += ipt_TO
+@@ -139,6 +139,7 @@ obj-$(CONFIG_IP_NF_TARGET_TOS) += ipt_TO
obj-$(CONFIG_IP_NF_TARGET_ECN) += ipt_ECN.o
obj-$(CONFIG_IP_NF_TARGET_DSCP) += ipt_DSCP.o
obj-$(CONFIG_IP_NF_TARGET_MARK) += ipt_MARK.o