aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.4/patches/609-netfilter_string.patch
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2009-10-03 23:51:10 +0000
committerNicolas Thill <nico@openwrt.org>2009-10-03 23:51:10 +0000
commit0e43e71159f1febb4926a4f4d56c60edc2cf0ebd (patch)
tree18bc80caa116785a9a729eddf7d67b5585f5a844 /target/linux/generic-2.4/patches/609-netfilter_string.patch
parentc9b0c63f0758f9d0f96846f0cdac3f167ba22b36 (diff)
downloadupstream-0e43e71159f1febb4926a4f4d56c60edc2cf0ebd.tar.gz
upstream-0e43e71159f1febb4926a4f4d56c60edc2cf0ebd.tar.bz2
upstream-0e43e71159f1febb4926a4f4d56c60edc2cf0ebd.zip
remove ipset support from core, it is now provided by xtables-addons from the packages feed
SVN-Revision: 17844
Diffstat (limited to 'target/linux/generic-2.4/patches/609-netfilter_string.patch')
-rw-r--r--target/linux/generic-2.4/patches/609-netfilter_string.patch4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/generic-2.4/patches/609-netfilter_string.patch b/target/linux/generic-2.4/patches/609-netfilter_string.patch
index baec7b2371..87934eda74 100644
--- a/target/linux/generic-2.4/patches/609-netfilter_string.patch
+++ b/target/linux/generic-2.4/patches/609-netfilter_string.patch
@@ -21,7 +21,7 @@
+#endif /*_IPT_STRING_H*/
--- a/net/ipv4/netfilter/Config.in
+++ b/net/ipv4/netfilter/Config.in
-@@ -61,6 +61,7 @@ if [ "$CONFIG_IP_NF_IPTABLES" != "n" ];
+@@ -47,6 +47,7 @@ if [ "$CONFIG_IP_NF_IPTABLES" != "n" ];
fi
if [ "$CONFIG_EXPERIMENTAL" = "y" ]; then
dep_tristate ' Unclean match support (EXPERIMENTAL)' CONFIG_IP_NF_MATCH_UNCLEAN $CONFIG_IP_NF_IPTABLES
@@ -133,7 +133,7 @@
+module_exit(fini);
--- a/net/ipv4/netfilter/Makefile
+++ b/net/ipv4/netfilter/Makefile
-@@ -99,6 +99,7 @@ obj-$(CONFIG_IP_NF_MATCH_STATE) += ipt_s
+@@ -87,6 +87,7 @@ obj-$(CONFIG_IP_NF_MATCH_STATE) += ipt_s
obj-$(CONFIG_IP_NF_MATCH_CONNMARK) += ipt_connmark.o
obj-$(CONFIG_IP_NF_MATCH_CONNTRACK) += ipt_conntrack.o
obj-$(CONFIG_IP_NF_MATCH_UNCLEAN) += ipt_unclean.o