aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.4/patches/606-netfilter_NETMAP.patch
diff options
context:
space:
mode:
authorAndy Boyett <agb@openwrt.org>2009-09-10 10:06:35 +0000
committerAndy Boyett <agb@openwrt.org>2009-09-10 10:06:35 +0000
commit22dfa7ae22c4c5eef2cd08e2c0e76ada5bf7fca8 (patch)
treeb4460277cbaf35402d23dbf83a18bc76cd27cc73 /target/linux/generic-2.4/patches/606-netfilter_NETMAP.patch
parent7c6ce6633008c17e08b422d8d2f45b29ecf52d99 (diff)
downloadupstream-22dfa7ae22c4c5eef2cd08e2c0e76ada5bf7fca8.tar.gz
upstream-22dfa7ae22c4c5eef2cd08e2c0e76ada5bf7fca8.tar.bz2
upstream-22dfa7ae22c4c5eef2cd08e2c0e76ada5bf7fca8.zip
refresh patches
SVN-Revision: 17553
Diffstat (limited to 'target/linux/generic-2.4/patches/606-netfilter_NETMAP.patch')
-rw-r--r--target/linux/generic-2.4/patches/606-netfilter_NETMAP.patch30
1 files changed, 11 insertions, 19 deletions
diff --git a/target/linux/generic-2.4/patches/606-netfilter_NETMAP.patch b/target/linux/generic-2.4/patches/606-netfilter_NETMAP.patch
index 064f74f928..adc0a81af7 100644
--- a/target/linux/generic-2.4/patches/606-netfilter_NETMAP.patch
+++ b/target/linux/generic-2.4/patches/606-netfilter_NETMAP.patch
@@ -1,8 +1,6 @@
-Index: linux-2.4.37.5/Documentation/Configure.help
-===================================================================
---- linux-2.4.37.5.orig/Documentation/Configure.help 2009-09-03 00:09:38.000000000 -0700
-+++ linux-2.4.37.5/Documentation/Configure.help 2009-09-03 00:12:30.000000000 -0700
-@@ -3086,6 +3086,17 @@
+--- a/Documentation/Configure.help
++++ b/Documentation/Configure.help
+@@ -3086,6 +3086,17 @@ CONFIG_IP_NF_TARGET_REDIRECT
If you want to compile it as a module, say M here and read
<file:Documentation/modules.txt>. If unsure, say `N'.
@@ -20,11 +18,9 @@ Index: linux-2.4.37.5/Documentation/Configure.help
Packet mangling
CONFIG_IP_NF_MANGLE
This option adds a `mangle' table to iptables: see the man page for
-Index: linux-2.4.37.5/net/ipv4/netfilter/Config.in
-===================================================================
---- linux-2.4.37.5.orig/net/ipv4/netfilter/Config.in 2009-09-03 00:09:38.000000000 -0700
-+++ linux-2.4.37.5/net/ipv4/netfilter/Config.in 2009-09-03 00:14:38.000000000 -0700
-@@ -63,6 +63,7 @@
+--- a/net/ipv4/netfilter/Config.in
++++ b/net/ipv4/netfilter/Config.in
+@@ -63,6 +63,7 @@ if [ "$CONFIG_IP_NF_IPTABLES" != "n" ];
define_bool CONFIG_IP_NF_NAT_NEEDED y
dep_tristate ' MASQUERADE target support' CONFIG_IP_NF_TARGET_MASQUERADE $CONFIG_IP_NF_NAT
dep_tristate ' REDIRECT target support' CONFIG_IP_NF_TARGET_REDIRECT $CONFIG_IP_NF_NAT
@@ -32,10 +28,8 @@ Index: linux-2.4.37.5/net/ipv4/netfilter/Config.in
if [ "$CONFIG_IP_NF_AMANDA" = "m" ]; then
define_tristate CONFIG_IP_NF_NAT_AMANDA m
else
-Index: linux-2.4.37.5/net/ipv4/netfilter/ipt_NETMAP.c
-===================================================================
---- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.4.37.5/net/ipv4/netfilter/ipt_NETMAP.c 2009-09-03 00:12:30.000000000 -0700
+--- /dev/null
++++ b/net/ipv4/netfilter/ipt_NETMAP.c
@@ -0,0 +1,112 @@
+/* NETMAP - static NAT mapping of IP network addresses (1:1).
+ The mapping can be applied to source (POSTROUTING),
@@ -149,11 +143,9 @@ Index: linux-2.4.37.5/net/ipv4/netfilter/ipt_NETMAP.c
+
+module_init(init);
+module_exit(fini);
-Index: linux-2.4.37.5/net/ipv4/netfilter/Makefile
-===================================================================
---- linux-2.4.37.5.orig/net/ipv4/netfilter/Makefile 2009-09-03 00:09:38.000000000 -0700
-+++ linux-2.4.37.5/net/ipv4/netfilter/Makefile 2009-09-03 00:12:30.000000000 -0700
-@@ -99,6 +99,7 @@
+--- a/net/ipv4/netfilter/Makefile
++++ b/net/ipv4/netfilter/Makefile
+@@ -99,6 +99,7 @@ obj-$(CONFIG_IP_NF_TARGET_DSCP) += ipt_D
obj-$(CONFIG_IP_NF_TARGET_MARK) += ipt_MARK.o
obj-$(CONFIG_IP_NF_TARGET_MASQUERADE) += ipt_MASQUERADE.o
obj-$(CONFIG_IP_NF_TARGET_REDIRECT) += ipt_REDIRECT.o