aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.4/patches/605-netfilter_TTL.patch
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2009-05-28 15:55:54 +0000
committerFlorian Fainelli <florian@openwrt.org>2009-05-28 15:55:54 +0000
commit53e16b5d4d8eb50376e34a6d6a692b4625cc8c74 (patch)
tree29cf5a36a9d1ac76ef4686d2f72983352d2bb76f /target/linux/generic-2.4/patches/605-netfilter_TTL.patch
parentc52e64fdbf3a4f4b9910a84ff147e3f1732535cc (diff)
downloadupstream-53e16b5d4d8eb50376e34a6d6a692b4625cc8c74.tar.gz
upstream-53e16b5d4d8eb50376e34a6d6a692b4625cc8c74.tar.bz2
upstream-53e16b5d4d8eb50376e34a6d6a692b4625cc8c74.zip
[brcm-2.4] update to 2.4.37, tested on wrt54gs (#4766)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@16144 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/generic-2.4/patches/605-netfilter_TTL.patch')
-rw-r--r--target/linux/generic-2.4/patches/605-netfilter_TTL.patch10
1 files changed, 5 insertions, 5 deletions
diff --git a/target/linux/generic-2.4/patches/605-netfilter_TTL.patch b/target/linux/generic-2.4/patches/605-netfilter_TTL.patch
index 0171505269..fe2b7ff724 100644
--- a/target/linux/generic-2.4/patches/605-netfilter_TTL.patch
+++ b/target/linux/generic-2.4/patches/605-netfilter_TTL.patch
@@ -1,8 +1,8 @@
--- a/Documentation/Configure.help
+++ b/Documentation/Configure.help
-@@ -3209,6 +3209,15 @@ CONFIG_IP_NF_TARGET_LOG
+@@ -3220,6 +3220,15 @@ CONFIG_IP_NF_TARGET_CLASSIFY
If you want to compile it as a module, say M here and read
- <file:Documentation/modules.txt>. If unsure, say `N'.
+ Documentation/modules.txt. If unsure, say `N'.
+TTL target support
+CONFIG_IP_NF_TARGET_TTL
@@ -42,8 +42,8 @@
+#endif
--- a/net/ipv4/netfilter/Config.in
+++ b/net/ipv4/netfilter/Config.in
-@@ -125,6 +125,7 @@ if [ "$CONFIG_IP_NF_IPTABLES" != "n" ];
- dep_tristate ' MARK target support' CONFIG_IP_NF_TARGET_MARK $CONFIG_IP_NF_MANGLE
+@@ -126,6 +126,7 @@ if [ "$CONFIG_IP_NF_IPTABLES" != "n" ];
+ dep_tristate ' CLASSIFY target support (EXPERIMENTAL)' CONFIG_IP_NF_TARGET_CLASSIFY $CONFIG_IP_NF_MANGLE
fi
dep_tristate ' LOG target support' CONFIG_IP_NF_TARGET_LOG $CONFIG_IP_NF_IPTABLES
+ dep_tristate ' TTL target support' CONFIG_IP_NF_TARGET_TTL $CONFIG_IP_NF_IPTABLES
@@ -165,7 +165,7 @@
+module_exit(fini);
--- a/net/ipv4/netfilter/Makefile
+++ b/net/ipv4/netfilter/Makefile
-@@ -109,6 +109,7 @@ obj-$(CONFIG_IP_NF_TARGET_MASQUERADE) +=
+@@ -110,6 +110,7 @@ obj-$(CONFIG_IP_NF_TARGET_MASQUERADE) +=
obj-$(CONFIG_IP_NF_TARGET_REDIRECT) += ipt_REDIRECT.o
obj-$(CONFIG_IP_NF_NAT_SNMP_BASIC) += ip_nat_snmp_basic.o
obj-$(CONFIG_IP_NF_TARGET_LOG) += ipt_LOG.o