aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic-2.4/patches/050-build_flags.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2010-06-26 20:42:18 +0000
committerFelix Fietkau <nbd@openwrt.org>2010-06-26 20:42:18 +0000
commit95c5443b843c7875794c17aeba33213b71ba4dbb (patch)
tree0c25039640bb2607a15f2792558ea5b2b4c1a48d /target/linux/generic-2.4/patches/050-build_flags.patch
parentc4f3caef75c247bcce4502391c072e10f741430a (diff)
downloadupstream-95c5443b843c7875794c17aeba33213b71ba4dbb.tar.gz
upstream-95c5443b843c7875794c17aeba33213b71ba4dbb.tar.bz2
upstream-95c5443b843c7875794c17aeba33213b71ba4dbb.zip
remove generic linux 2.4 support
SVN-Revision: 21948
Diffstat (limited to 'target/linux/generic-2.4/patches/050-build_flags.patch')
-rw-r--r--target/linux/generic-2.4/patches/050-build_flags.patch81
1 files changed, 0 insertions, 81 deletions
diff --git a/target/linux/generic-2.4/patches/050-build_flags.patch b/target/linux/generic-2.4/patches/050-build_flags.patch
deleted file mode 100644
index dd4b62ced9..0000000000
--- a/target/linux/generic-2.4/patches/050-build_flags.patch
+++ /dev/null
@@ -1,81 +0,0 @@
---- a/arch/mips/Makefile
-+++ b/arch/mips/Makefile
-@@ -44,10 +44,10 @@ MAKEBOOT = $(MAKE) -C arch/$(ARCH)/boot
- GCCFLAGS := -I $(TOPDIR)/include/asm/gcc
- GCCFLAGS += -G 0 -mno-abicalls -fno-pic -pipe
- GCCFLAGS += $(call check_gcc, -finline-limit=100000,)
--LINKFLAGS += -G 0 -static -n
--MODFLAGS += -mlong-calls
-+LINKFLAGS += -G 0 -static -n -nostdlib
-+MODFLAGS += -mlong-calls -fno-common
-
--ifdef CONFIG_DEBUG_INFO
-+ifdef CONFIG_REMOTE_DEBUG
- GCCFLAGS += -g
- ifdef CONFIG_SB1XXX_CORELIS
- GCCFLAGS += -mno-sched-prolog -fno-omit-frame-pointer
-@@ -69,13 +69,13 @@ endif
- set_gccflags = $(shell \
- while :; do \
- cpu=$(1); isa=-$(2); \
-- for gcc_opt in -march= -mcpu=; do \
-+ for gcc_opt in -march= -mtune=; do \
- $(CC) $$gcc_opt$$cpu $$isa -S -o /dev/null \
- -xc /dev/null > /dev/null 2>&1 && \
- break 2; \
- done; \
- cpu=$(3); isa=-$(4); \
-- for gcc_opt in -march= -mcpu=; do \
-+ for gcc_opt in -march= -mtune=; do \
- $(CC) $$gcc_opt$$cpu $$isa -S -o /dev/null \
- -xc /dev/null > /dev/null 2>&1 && \
- break 2; \
-@@ -90,7 +90,7 @@ else \
- fi; \
- gas_abi=-Wa,-32; gas_cpu=$$cpu; gas_isa=-Wa,$$isa; \
- while :; do \
-- for gas_opt in -Wa,-march= -Wa,-mcpu=; do \
-+ for gas_opt in -Wa,-march= -Wa,-mtune=; do \
- $(CC) $$gas_abi $$gas_opt$$cpu $$gas_isa -Wa,-Z -c \
- -o /dev/null -xassembler /dev/null > /dev/null 2>&1 && \
- break 2; \
-@@ -172,6 +172,7 @@ endif
- endif
-
- AFLAGS += $(GCCFLAGS)
-+ASFLAGS += $(GCCFLAGS)
- CFLAGS += $(GCCFLAGS)
-
- LD += -m $(ld-emul)
---- a/Makefile
-+++ b/Makefile
-@@ -17,7 +17,7 @@ HPATH = $(TOPDIR)/include
- FINDHPATH = $(HPATH)/asm $(HPATH)/linux $(HPATH)/scsi $(HPATH)/net $(HPATH)/math-emu
-
- HOSTCC = gcc
--HOSTCFLAGS = -Wall -Wstrict-prototypes -O2 -fomit-frame-pointer
-+HOSTCFLAGS = -Wall -Wstrict-prototypes -Os -fomit-frame-pointer
-
- CROSS_COMPILE =
-
-@@ -88,10 +88,9 @@ export MODLIB
- #
- # standard CFLAGS
- #
--
- CPPFLAGS := -D__KERNEL__ -I$(HPATH)
-
--CFLAGS := $(CPPFLAGS) -Wall -Wstrict-prototypes -Wno-trigraphs -O2 \
-+CFLAGS := $(CPPFLAGS) -Wall -Wstrict-prototypes -Wno-trigraphs -Os \
- -fno-strict-aliasing -fno-common
- CFLAGS += -fno-builtin-strpbrk -fno-builtin-sprintf
- ifndef CONFIG_FRAME_POINTER
-@@ -108,6 +107,8 @@ CFLAGS += $(call check_gcc,-Wno-pointer-
- # disable stupid and dangerous "optimization" in gcc 3.2+
- CFLAGS += $(call check_gcc,-fno-delete-null-pointer-checks,)
-
-+CFLAGS += $(call check_gcc, -funit-at-a-time,)
-+
- #
- # ROOT_DEV specifies the default root-device when making the image.
- # This can be either FLOPPY, CURRENT, /dev/xxxx or empty, in which case