aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/gemini/image
diff options
context:
space:
mode:
authorLinus Walleij <linus.walleij@linaro.org>2018-10-18 11:30:27 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2018-10-20 16:13:39 +0200
commit10ec966f7ba7471a8af437c317cdcc5ef8865e8d (patch)
tree8716efe946e4f868d7c861287383d0d364c01f2b /target/linux/gemini/image
parentb2c68ceea76a41a484d24a12d20c6988dd59e83f (diff)
downloadupstream-10ec966f7ba7471a8af437c317cdcc5ef8865e8d.tar.gz
upstream-10ec966f7ba7471a8af437c317cdcc5ef8865e8d.tar.bz2
upstream-10ec966f7ba7471a8af437c317cdcc5ef8865e8d.zip
gemini: Break out USB to packages
This creates a new kernel package for the fotg210 host controller and uses that with the gemini to shrink the kernel. The SQ201 needs the USB2 PCI package as well. The build system required me to make kernel_oldconfig beofore it would build without errors so some minor unrelated Kconfig entries are changed. Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
Diffstat (limited to 'target/linux/gemini/image')
-rw-r--r--target/linux/gemini/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/gemini/image/Makefile b/target/linux/gemini/image/Makefile
index a05b7111b5..9e7daea03a 100644
--- a/target/linux/gemini/image/Makefile
+++ b/target/linux/gemini/image/Makefile
@@ -137,7 +137,7 @@ define Device/sq201
DEVICE_TITLE := ITian Square One SQ201
IMAGES += sq201-image
IMAGE/sq201-image := sq201-images
- DEVICE_PACKAGES := $(GEMINI_NAS_PACKAGES) rt61-pci
+ DEVICE_PACKAGES := $(GEMINI_NAS_PACKAGES) rt61-pci usb2-pci
endef
TARGET_DEVICES += sq201