aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ep93xx
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2010-04-12 23:15:56 +0000
committerNicolas Thill <nico@openwrt.org>2010-04-12 23:15:56 +0000
commite2b57ecf5f1f50f7b5f5644e483e06dd67a3cb5f (patch)
treef8563604e7685c30b0a2a675ca80379a34114565 /target/linux/ep93xx
parent040c06438896144dfe148910f922a0d9bb0058b0 (diff)
downloadupstream-e2b57ecf5f1f50f7b5f5644e483e06dd67a3cb5f.tar.gz
upstream-e2b57ecf5f1f50f7b5f5644e483e06dd67a3cb5f.tar.bz2
upstream-e2b57ecf5f1f50f7b5f5644e483e06dd67a3cb5f.zip
define a shared IMG_PREFIX variable used as a basename for image files, it contains board & subtarget infos (if appropriate) allowing subtargets to share the same bin directory without overwriting each other's files
SVN-Revision: 20834
Diffstat (limited to 'target/linux/ep93xx')
-rw-r--r--target/linux/ep93xx/image/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/target/linux/ep93xx/image/Makefile b/target/linux/ep93xx/image/Makefile
index 129db3f381..4394a6a04e 100644
--- a/target/linux/ep93xx/image/Makefile
+++ b/target/linux/ep93xx/image/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2009 OpenWrt.org
+# Copyright (C) 2009-2010 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -15,16 +15,16 @@ define Image/BuildKernel
endef
define Image/Build/jffs2-64k
- dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(1).img bs=64k conv=sync
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-$(1).img bs=64k conv=sync
endef
define Image/Build/jffs2-128k
- dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(1).img bs=128k conv=sync
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-$(1).img bs=128k conv=sync
endef
define Image/Build/squashfs
$(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
- dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(1).img bs=128k conv=sync
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-$(1).img bs=128k conv=sync
endef
define Image/Build