aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ep93xx/modules.mk
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2012-07-24 19:42:49 +0000
committerFlorian Fainelli <florian@openwrt.org>2012-07-24 19:42:49 +0000
commit598ef2a2e0ad8a28de8ec5e108d638a8c38ab2a1 (patch)
treeffb617cb803b234a57465fc95a0b30ddca89e17b /target/linux/ep93xx/modules.mk
parent0db5f35846fb7cf9d57cffd5c43d18a2752055ce (diff)
downloadupstream-598ef2a2e0ad8a28de8ec5e108d638a8c38ab2a1.tar.gz
upstream-598ef2a2e0ad8a28de8ec5e108d638a8c38ab2a1.tar.bz2
upstream-598ef2a2e0ad8a28de8ec5e108d638a8c38ab2a1.zip
package ep93xx touchscreen driver as a module
SVN-Revision: 32799
Diffstat (limited to 'target/linux/ep93xx/modules.mk')
-rw-r--r--target/linux/ep93xx/modules.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/target/linux/ep93xx/modules.mk b/target/linux/ep93xx/modules.mk
index 3fc691f4c2..94d2c83f82 100644
--- a/target/linux/ep93xx/modules.mk
+++ b/target/linux/ep93xx/modules.mk
@@ -68,3 +68,18 @@ define KernelPackage/sound-soc-ep93xx-simone/description
endef
$(eval $(call KernelPackage,sound-soc-ep93xx-simone))
+
+define KernelPackage/touchscreen-ep93xx
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=EP93xx input touchscreen support
+ KCONFIG:=CONFIG_TOUCHSCREEN_EP93XX
+ FILES:=$(LINUX_DIR)/drivers/input/touchscreen/ep93xx_ts.ko
+ AUTOLOAD:=$(call AutoLoad,51,ep93xx_ts)
+endef
+
+define KernelPackage/touchscreen-ep93xx/description
+ EP93xx SoC input touchscreen support
+endef
+
+$(eval $(call KernelPackage,touchscreen-ep93xx))
+