aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/coldfire/patches/039-mcfv4e_kbuild_flags_update.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2009-06-23 21:04:37 +0000
committerImre Kaloz <kaloz@openwrt.org>2009-06-23 21:04:37 +0000
commitc49f135f72f98633653300bab5b0ac993b03c6be (patch)
tree50929b27bcea9ab4dc74b041d6e90967473301fa /target/linux/coldfire/patches/039-mcfv4e_kbuild_flags_update.patch
parent50f2abfa16a2b509955312d1776beeece662c61b (diff)
downloadupstream-c49f135f72f98633653300bab5b0ac993b03c6be.tar.gz
upstream-c49f135f72f98633653300bab5b0ac993b03c6be.tar.bz2
upstream-c49f135f72f98633653300bab5b0ac993b03c6be.zip
use broken-out patches for the coldfire to make it easier to follow differences against the bsp
SVN-Revision: 16547
Diffstat (limited to 'target/linux/coldfire/patches/039-mcfv4e_kbuild_flags_update.patch')
-rw-r--r--target/linux/coldfire/patches/039-mcfv4e_kbuild_flags_update.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/target/linux/coldfire/patches/039-mcfv4e_kbuild_flags_update.patch b/target/linux/coldfire/patches/039-mcfv4e_kbuild_flags_update.patch
new file mode 100644
index 0000000000..e560749569
--- /dev/null
+++ b/target/linux/coldfire/patches/039-mcfv4e_kbuild_flags_update.patch
@@ -0,0 +1,32 @@
+From ea71d637a9d8606624056fad67d050face9fc03c Mon Sep 17 00:00:00 2001
+From: Kurt Mahan <kmahan@freescale.com>
+Date: Fri, 15 Feb 2008 15:32:35 -0700
+Subject: [PATCH] Update to use KBUILD_ for CFLAGS and AFLAGS.
+
+LTIBName: mcfv4e-kbuild-flags-update
+Signed-off-by: Kurt Mahan <kmahan@freescale.com>
+---
+ arch/m68k/Makefile | 5 +++--
+ 1 files changed, 3 insertions(+), 2 deletions(-)
+
+--- a/arch/m68k/Makefile
++++ b/arch/m68k/Makefile
+@@ -33,6 +33,7 @@ LDFLAGS_vmlinux = -N
+ endif
+
+ ifdef CONFIG_COLDFIRE
++# OBJCOPYFLAGS := -R .note -R .note.gnu.build-id -R .comment -S
+ # LDFLAGS_vmlinux = --verbose
+ endif
+
+@@ -59,8 +60,8 @@ endif
+ endif
+
+ ifdef CONFIG_M54455
+-CFLAGS := $(CFLAGS) -march=isac -mcpu=54455 -msoft-float -g
+-AFLAGS := $(AFLAGS) -march=isac -mcpu=54455 -msoft-float
++KBUILD_CFLAGS += -march=isac -mcpu=54455 -msoft-float -g
++KBUILD_AFLAGS += -march=isac -mcpu=54455 -msoft-float
+ endif
+
+ ifdef CONFIG_KGDB