aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/cobalt
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2012-07-25 14:01:49 +0000
committerFlorian Fainelli <florian@openwrt.org>2012-07-25 14:01:49 +0000
commit6882629b8c3fef2cce1fc4ad2ac7ed0e27316133 (patch)
tree7daed9f2b17f24375d5704366b244af5be89150d /target/linux/cobalt
parentd5a1f05020e5ab340d45d9c1b09de29f0d7cd996 (diff)
downloadupstream-6882629b8c3fef2cce1fc4ad2ac7ed0e27316133.tar.gz
upstream-6882629b8c3fef2cce1fc4ad2ac7ed0e27316133.tar.bz2
upstream-6882629b8c3fef2cce1fc4ad2ac7ed0e27316133.zip
[cobalt] package buttons driver separately
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@32841 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/cobalt')
-rw-r--r--target/linux/cobalt/config-3.34
-rw-r--r--target/linux/cobalt/modules.mk15
2 files changed, 15 insertions, 4 deletions
diff --git a/target/linux/cobalt/config-3.3 b/target/linux/cobalt/config-3.3
index ccc5839513..315ef15865 100644
--- a/target/linux/cobalt/config-3.3
+++ b/target/linux/cobalt/config-3.3
@@ -85,10 +85,6 @@ CONFIG_HZ=250
CONFIG_HZ_250=y
CONFIG_I8253=y
CONFIG_I8259=y
-CONFIG_INPUT=y
-CONFIG_INPUT_COBALT_BTNS=y
-CONFIG_INPUT_EVDEV=y
-CONFIG_INPUT_POLLDEV=y
# CONFIG_IP_ADVANCED_ROUTER is not set
# CONFIG_IP_MULTICAST is not set
CONFIG_IRQ_CPU=y
diff --git a/target/linux/cobalt/modules.mk b/target/linux/cobalt/modules.mk
index fcba757312..79cef87cac 100644
--- a/target/linux/cobalt/modules.mk
+++ b/target/linux/cobalt/modules.mk
@@ -19,3 +19,18 @@ define KernelPackage/fb-cobalt/descriptione
endef
$(eval $(call KernelPackage,fb-cobalt))
+
+define KernelPackage/cobalt-btns
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=Cobalt buttons support
+ DEPENDS:=@TARGET_cobalt +kmod-input-evdev +kmod-input-polldev
+ KCONFIG:=CONFIG_INPUT_COBALT_BTNS
+ FILES:=$(LINUX_DIR)/drivers/input/misc/cobalt_btns.ko
+ AUTOLOAD:=$(call AutoLoad,62,cobalt_btns)
+endef
+
+define KernelPackage/cobalt-btns/description
+ Kernel module for the Cobalt Microservers buttons
+endef
+
+$(eval $(call KernelPackage,cobalt-btns))