aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/cns21xx/patches-2.6.36/003-arm-introduce-fa-platform.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2010-12-30 17:19:16 +0000
committerGabor Juhos <juhosg@openwrt.org>2010-12-30 17:19:16 +0000
commit72ba27ae72480d5a23b77b5760d81d4142f8181b (patch)
treee3572d5b242208667ee40cbfd0b37fc55de290e6 /target/linux/cns21xx/patches-2.6.36/003-arm-introduce-fa-platform.patch
parenta718ebf1ed8956ec84ccd2d7f79653c0c0c74e5b (diff)
downloadupstream-72ba27ae72480d5a23b77b5760d81d4142f8181b.tar.gz
upstream-72ba27ae72480d5a23b77b5760d81d4142f8181b.tar.bz2
upstream-72ba27ae72480d5a23b77b5760d81d4142f8181b.zip
cns21xx: add initial support for the Cavium CNS21xx SoC
SVN-Revision: 24859
Diffstat (limited to 'target/linux/cns21xx/patches-2.6.36/003-arm-introduce-fa-platform.patch')
-rw-r--r--target/linux/cns21xx/patches-2.6.36/003-arm-introduce-fa-platform.patch47
1 files changed, 47 insertions, 0 deletions
diff --git a/target/linux/cns21xx/patches-2.6.36/003-arm-introduce-fa-platform.patch b/target/linux/cns21xx/patches-2.6.36/003-arm-introduce-fa-platform.patch
new file mode 100644
index 0000000000..811d115af8
--- /dev/null
+++ b/target/linux/cns21xx/patches-2.6.36/003-arm-introduce-fa-platform.patch
@@ -0,0 +1,47 @@
+--- a/arch/arm/Kconfig
++++ b/arch/arm/Kconfig
+@@ -954,10 +954,15 @@ source "arch/arm/mach-vexpress/Kconfig"
+
+ source "arch/arm/mach-w90x900/Kconfig"
+
++source "arch/arm/plat-fa/Kconfig"
++
+ # Definitions to make life easier
+ config ARCH_ACORN
+ bool
+
++config PLAT_FA
++ bool
++
+ config PLAT_IOP
+ bool
+ select GENERIC_CLOCKEVENTS
+--- a/arch/arm/Makefile
++++ b/arch/arm/Makefile
+@@ -202,6 +202,7 @@ plat-$(CONFIG_ARCH_MXC) := mxc
+ plat-$(CONFIG_ARCH_OMAP) := omap
+ plat-$(CONFIG_ARCH_S3C64XX) := samsung
+ plat-$(CONFIG_ARCH_STMP3XXX) := stmp3xxx
++plat-$(CONFIG_PLAT_FA) := fa
+ plat-$(CONFIG_PLAT_IOP) := iop
+ plat-$(CONFIG_PLAT_NOMADIK) := nomadik
+ plat-$(CONFIG_PLAT_ORION) := orion
+--- /dev/null
++++ b/arch/arm/plat-fa/Makefile
+@@ -0,0 +1,10 @@
++#
++# Makefile for the linux kernel.
++#
++
++obj-y :=
++
++obj-m :=
++obj-n :=
++obj- :=
++
+--- /dev/null
++++ b/arch/arm/plat-fa/Kconfig
+@@ -0,0 +1,3 @@
++if PLAT_FA
++
++endif