aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/cavium-octeon/image
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2009-05-06 18:12:49 +0000
committerFlorian Fainelli <florian@openwrt.org>2009-05-06 18:12:49 +0000
commit70f94ae2ab0e5460b817ad7b670f071d904d8bab (patch)
tree89145ffa8eb280689e41008eacbd8057e3ac0dc7 /target/linux/cavium-octeon/image
parent731a0e4791eafdb464c13b02383fae6711e72813 (diff)
downloadupstream-70f94ae2ab0e5460b817ad7b670f071d904d8bab.tar.gz
upstream-70f94ae2ab0e5460b817ad7b670f071d904d8bab.tar.bz2
upstream-70f94ae2ab0e5460b817ad7b670f071d904d8bab.zip
add support for the Cavium Octeon SoC, tested on a Mototech evaluation board
SVN-Revision: 15640
Diffstat (limited to 'target/linux/cavium-octeon/image')
-rw-r--r--target/linux/cavium-octeon/image/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/target/linux/cavium-octeon/image/Makefile b/target/linux/cavium-octeon/image/Makefile
new file mode 100644
index 0000000000..7189a9cffa
--- /dev/null
+++ b/target/linux/cavium-octeon/image/Makefile
@@ -0,0 +1,26 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+define Image/BuildKernel
+ # Workaround pre-SDK-1.9.0 u-boot versions not handling the .notes section
+ $(TARGET_CROSS)strip -R .notes $(KDIR)/vmlinux.elf -o $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.elf
+ $(STAGING_DIR_HOST)/bin/lzma e $(KDIR)/vmlinux $(KDIR)/vmlinux.bin.l7
+ dd if=$(KDIR)/vmlinux.bin.l7 of=$(BIN_DIR)/openwrt-$(BOARD)-vmlinux.lzma bs=65536 conv=sync
+endef
+
+define Image/Build/squashfs
+ $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
+endef
+
+define Image/Build
+ $(call Image/Build/$(1))
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-root.$(1) bs=128k conv=sync
+endef
+
+$(eval $(call BuildImage))