aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm63xx
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-03-25 15:34:45 +0000
committerJonas Gorski <jogo@openwrt.org>2015-03-25 15:34:45 +0000
commited7bef4f55a8a5ec4c37fdaff263541f978888b4 (patch)
tree7edcb59fd083d674c85d2823c2e1b7f35c5272e4 /target/linux/brcm63xx
parent3bc36b563e08c8620256855876b90a83023b8fb1 (diff)
downloadupstream-ed7bef4f55a8a5ec4c37fdaff263541f978888b4.tar.gz
upstream-ed7bef4f55a8a5ec4c37fdaff263541f978888b4.tar.bz2
upstream-ed7bef4f55a8a5ec4c37fdaff263541f978888b4.zip
brcm63xx: hcsimage: respect load address
Respect the vmlinux load address when generating images. Signed-off-by: Jonas Gorski <jogo@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44983 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/brcm63xx')
-rwxr-xr-xtarget/linux/brcm63xx/image/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/target/linux/brcm63xx/image/Makefile b/target/linux/brcm63xx/image/Makefile
index 1913feb646..47756bf39b 100755
--- a/target/linux/brcm63xx/image/Makefile
+++ b/target/linux/brcm63xx/image/Makefile
@@ -119,7 +119,8 @@ define Image/Build/HCSDTB
# Generate the image
$(STAGING_DIR_HOST)/bin/hcsmakeimage --magic_byte=$(4) \
--rev_maj=$(5) --rev_min=$(6) --input_file=$(KDIR)/$(7) \
- --output_file=$(BIN_DIR)/openwrt-$(2)-$(1).bin
+ --output_file=$(BIN_DIR)/openwrt-$(2)-$(1).bin \
+ --ldaddress=$(LOADADDR)
endef
define Image/Build/ChkDTB