aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm63xx
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2011-05-20 10:06:22 +0000
committerFlorian Fainelli <florian@openwrt.org>2011-05-20 10:06:22 +0000
commit6c8387fe1565127b5e366fd89d00350441ba7cd4 (patch)
tree9b28344c4e2b64202a4a3e154d64bc79f16bad69 /target/linux/brcm63xx
parent031ea08ef0295b6185b2c70de27e9bf640b21400 (diff)
downloadupstream-6c8387fe1565127b5e366fd89d00350441ba7cd4.tar.gz
upstream-6c8387fe1565127b5e366fd89d00350441ba7cd4.tar.bz2
upstream-6c8387fe1565127b5e366fd89d00350441ba7cd4.zip
add support for DSL-2640B rev B2
Signed-off-by: Adrian Feliks <mexit@o2.pl> SVN-Revision: 26958
Diffstat (limited to 'target/linux/brcm63xx')
-rw-r--r--target/linux/brcm63xx/base-files/etc/defconfig/D-4P-W/network14
-rwxr-xr-xtarget/linux/brcm63xx/base-files/lib/brcm63xx.sh5
-rw-r--r--target/linux/brcm63xx/image/Makefile4
-rw-r--r--target/linux/brcm63xx/patches-2.6.37/421-board-D4PW_correction.patch70
4 files changed, 91 insertions, 2 deletions
diff --git a/target/linux/brcm63xx/base-files/etc/defconfig/D-4P-W/network b/target/linux/brcm63xx/base-files/etc/defconfig/D-4P-W/network
new file mode 100644
index 0000000000..fa4844d1ac
--- /dev/null
+++ b/target/linux/brcm63xx/base-files/etc/defconfig/D-4P-W/network
@@ -0,0 +1,14 @@
+# Copyright (C) 2010 OpenWrt.org
+
+config interface loopback
+ option ifname lo
+ option proto static
+ option ipaddr 127.0.0.1
+ option netmask 255.0.0.0
+
+config interface lan
+ option ifname eth0
+ option type bridge
+ option proto static
+ option ipaddr 192.168.1.1
+ option netmask 255.255.255.0
diff --git a/target/linux/brcm63xx/base-files/lib/brcm63xx.sh b/target/linux/brcm63xx/base-files/lib/brcm63xx.sh
index 2c62928a55..d2ffabd176 100755
--- a/target/linux/brcm63xx/base-files/lib/brcm63xx.sh
+++ b/target/linux/brcm63xx/base-files/lib/brcm63xx.sh
@@ -59,6 +59,11 @@ brcm63xx_detect() {
brcm63xx_has_reset_button="true"
ifname=eth0
;;
+ "bcm63xx/D-4P-W "*)
+ status_led="power:green"
+ brcm63xx_has_reset_button="true"
+ ifname=eth0
+ ;;
*)
;;
esac
diff --git a/target/linux/brcm63xx/image/Makefile b/target/linux/brcm63xx/image/Makefile
index f1fa4f540e..8b15771105 100644
--- a/target/linux/brcm63xx/image/Makefile
+++ b/target/linux/brcm63xx/image/Makefile
@@ -189,8 +189,8 @@ define Image/Build
$(call Image/Build/CFE,$(1),96348GW-10,6348,DG834GT_DG834PN)
# Belkin f5d7633
$(call Image/Build/CFE,$(1),96348GW-10,6348,F5D7633)
- # D-Link DSL-2640B
- $(call Image/Build/CFE,$(1),D-4P-W,6348,DSL2640B)
+ # D-Link DSL-2640B, rev B2
+ $(call Image/Build/CFE,$(1),D-4P-W,6348,DSL2640B-B2)
# D-Link DSL-2740B/DSL-2741B, rev C2
$(call Image/Build/CFEFIXUP,$(1),96358GW,AW4139,6358,DSL274XB-C2)
# D-Link DSL-2740B/DSL-2741B, rev C3
diff --git a/target/linux/brcm63xx/patches-2.6.37/421-board-D4PW_correction.patch b/target/linux/brcm63xx/patches-2.6.37/421-board-D4PW_correction.patch
new file mode 100644
index 0000000000..540626a0b9
--- /dev/null
+++ b/target/linux/brcm63xx/patches-2.6.37/421-board-D4PW_correction.patch
@@ -0,0 +1,70 @@
+--- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
++++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
+@@ -522,42 +522,48 @@ static struct board_info __initdata boar
+ .name = "D-4P-W",
+ .expected_cpu_id = 0x6348,
+
+- .has_enet0 = 1,
+- .has_enet1 = 1,
++ .has_enet1 = 1,
+ .has_pci = 1,
+-
+- .enet0 = {
+- .has_phy = 1,
+- .use_internal_phy = 1,
+- },
++ .has_uart0 = 1,
++
+ .enet1 = {
+ .force_speed_100 = 1,
+ .force_duplex_full = 1,
+- },
+-
+- .has_ohci0 = 1,
+- .has_ehci0 = 1,
++ },
+
+ .leds = {
+ {
+- .name = "ppp",
++ .name = "power:green",
++ .gpio = 0,
++ .active_low = 1,
++ },
++ {
++ .name = "status",
++ .gpio = 3,
++ .active_low = 1,
++ },
++ {
++ .name = "internet:green",
+ .gpio = 4,
+ .active_low = 1,
+ },
+ {
+- .name = "ppp-fail",
++ .name = "internet:red",
+ .gpio = 5,
+ .active_low = 1,
+- },
++ },
++ },
++
++ .buttons = {
+ {
+- .name = "power",
+- .gpio = 0,
++ .desc = "reset",
++ .gpio = 7,
+ .active_low = 1,
+- .default_trigger = "default-on",
+-
++ .type = EV_KEY,
++ .code = KEY_RESTART,
++ .threshold = 3,
+ },
+ },
+-
+ };
+
+ static struct board_info __initdata board_spw500v = {